周赛

E 圆周率用acos(-1.0) 使用longlong
Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

A palindromic number or numeral palindrome is a 'symmetrical' number like 16461, that remains the same when its digits are reversed. In this problem you will be given an integer, you have to say whether the number is a palindromic number or not.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case starts with a line containing an integer n (0 ≤ n < 109).

Output

For each case, print the case number and 'Yes' if n is palindromic, otherwise print 'No'.

Sample Input

5

1

21

16161

523125

0

Sample Output

Case 1: Yes

Case 2: No

Case 3: Yes

Case 4: No

Case 5: Yes


#include<cstdio>
#include<math.h>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	int t,cont=0;
	long long n,m,sum;
	scanf("%d",&t);
	while(t--)
	{
		sum=0;
		scanf("%lld",&n);
		m=n;
		while(n!=0)
		{
			sum=sum+n%10;
			n=n/10;
			if(n==0)
			break;
			sum=sum*10;
		}
		if(sum==m)
		printf("Case %d: Yes\n",++cont);
		else
		printf("Case %d: No\n",++cont);
	}
	return 0;
}//EEEEEEEEEE

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值