首页
题库
状态
天梯
课程
比赛
排行榜
武则天
题目描述 我的提交 所有提交 换下一题
10049 : 凯的菱形
时间限制: 1000 MS
内存限制: 131072 KB
提交总数: 36
AC总数: 20
问题描述
打完一波农药,安琪拉感叹道:凯呀凯,你真是又帅又厉害!!!
凯是真帅,他的菱形也是帅:最外层是字母A,然后里一层是B,再里一层是C。。。
输入格式
第一行输入整数n(1<=n<=25),表示菱形的半径,直径是(n*2+1)
输出格式
输出对应的菱形
样例输入
2
样例输出
A
ABA
ABCBA
ABA
A
作者
zpl
来源
OneCode
题听题题题
#include<bits/stdc++.h>
using namespace std;
int a,b,c,d,f;
char e='A';
int main()
{
cin>>a;
for(int b=0;b<=a;b++)
{
for(int c=0;c<a-b;c++)
{
cout<<" ";
}
for(int d=0;d<=b;d++)
{
f=(int)e;
cout<<e;
f++;
e=(char)f;
}
f=(int)e-2;
for(int g=0;g<b;g++)
{
e=(char)f;
cout<<e;
f=(int)e;
f--;
}
cout<<endl;
e='A';
}
for(int b=0;b<a;b++)
{
for(int c=0;c<=b;c++)
{
cout<<" ";
}
for(int d=0;d<a-b;d++)
{
f=(int)e;
cout<<e;
f++;
e=(char)f;
}
f=(int)e-2;
for(int g=0;g<a-b-1;g++)
{
e=(char)f;
cout<<e;
f=(int)e;
f--;
}
e='A';
cout<<endl;
}
return 0;
}
- #include<bits/stdc++.h>
using namespace std;
int a,b,c,d,f;
char e=‘A’;
int main()
{
cin>>a;
for(int b=0;b<=a;b++)
{
for(int c=0;c<a-b;c++)
{
cout<<" “;
}
for(int d=0;d<=b;d++)
{
f=(int)e;
cout<<e;
f++;
e=(char)f;
}
f=(int)e-2;
for(int g=0;g<b;g++)
{
e=(char)f;
cout<<e;
f=(int)e;
f–;
}
cout<<endl;
e=‘A’;
}
for(int b=0;b<a;b++)
{
for(int c=0;c<=b;c++)
{
cout<<” ";
}
for(int d=0;d<a-b;d++)
{
f=(int)e;
cout<<e;
f++;
e=(char)f;
}
f=(int)e-2;
for(int g=0;g<a-b-1;g++)
{
e=(char)f;
cout<<e;
f=(int)e;
f–;
}
e=‘A’;
cout<<endl;
}
return 0;
}