10049 : 凯的菱形

首页
题库
状态
天梯
课程
比赛
排行榜
武则天
题目描述 我的提交 所有提交 换下一题

10049 : 凯的菱形
时间限制: 1000 MS
内存限制: 131072 KB
提交总数: 36
AC总数: 20

问题描述
打完一波农药,安琪拉感叹道:凯呀凯,你真是又帅又厉害!!!
凯是真帅,他的菱形也是帅:最外层是字母A,然后里一层是B,再里一层是C。。。
输入格式
第一行输入整数n(1<=n<=25),表示菱形的半径,直径是(n*2+1)
输出格式
输出对应的菱形
样例输入
2
样例输出
A
ABA
ABCBA
ABA
A
作者
zpl
来源
OneCode
题听题题题




#include<bits/stdc++.h>
using namespace std;
int a,b,c,d,f;
char e='A';
int main()
{
	cin>>a;
	for(int b=0;b<=a;b++)
	{
		for(int c=0;c<a-b;c++)
		{
			cout<<" ";
		}
		for(int d=0;d<=b;d++)
		{
			f=(int)e;
			cout<<e;
			f++;
			e=(char)f;
		}
        f=(int)e-2;
		for(int g=0;g<b;g++)
		{
			e=(char)f;
			cout<<e;
			f=(int)e;
			f--;
		}
		cout<<endl;
		e='A';
	}
	for(int b=0;b<a;b++)
	{
		for(int c=0;c<=b;c++)
		{
			cout<<" ";
		}
		for(int d=0;d<a-b;d++)
		{
			f=(int)e;
			cout<<e;
			f++;
			e=(char)f;
		}
		f=(int)e-2;
		for(int g=0;g<a-b-1;g++)
		{
			e=(char)f;
			cout<<e;
			f=(int)e;
			f--;
		}
		e='A';
		cout<<endl;
	}
	return 0;
 }

  1. #include<bits/stdc++.h>
    using namespace std;
    int a,b,c,d,f;
    char e=‘A’;
    int main()
    {
    cin>>a;
    for(int b=0;b<=a;b++)
    {
    for(int c=0;c<a-b;c++)
    {
    cout<<" “;
    }
    for(int d=0;d<=b;d++)
    {
    f=(int)e;
    cout<<e;
    f++;
    e=(char)f;
    }
    f=(int)e-2;
    for(int g=0;g<b;g++)
    {
    e=(char)f;
    cout<<e;
    f=(int)e;
    f–;
    }
    cout<<endl;
    e=‘A’;
    }
    for(int b=0;b<a;b++)
    {
    for(int c=0;c<=b;c++)
    {
    cout<<” ";
    }
    for(int d=0;d<a-b;d++)
    {
    f=(int)e;
    cout<<e;
    f++;
    e=(char)f;
    }
    f=(int)e-2;
    for(int g=0;g<a-b-1;g++)
    {
    e=(char)f;
    cout<<e;
    f=(int)e;
    f–;
    }
    e=‘A’;
    cout<<endl;
    }
    return 0;
    }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

oj_onecode

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值