nyoj题目121:另类乘法

另类乘法

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 1
描述

Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, A*B is equal to the sum of all possible pairwise products between the digits of A and B. For example, the product 123*45 is equal to 1*4 + 1*5 + 2*4 + 2*5 + 3*4 + 3*5 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie's style of multiplication.

输入
The first Line of the input is a positive integer T,indicates the number of the test cases;
In every case,the input is in one line,contains two positive interger A,B
输出
For every case,output the multiplication in Bessie's style.
样例输入
1
123 45
样例输出
54



#include <stdio.h>

main()
{
 int n, c[100], d[100], i, j, k, l;
 long a, b, sum;
 scanf("%d", &n);


 while (n--)
 {
  scanf ("%ld %ld", &a, &b);
  j = i = -1;
  
  while(a)
  {
   i++;
   c[i] = a % 10;
   a = a / 10;
  }                   //求出每一位的数
  while(b)
  {
   j++;
   d[j] = b % 10;
   b = b / 10;
  }                   //求出每一位的数
  
  sum = 0;
  for (k=0;k<=i;k++)
   for (l=0;l<=j;l++)
    sum += c[k] * d[l];
  
  printf ("%ld\n", sum);
 }
}


优秀代码:
#include<stdio.h>
char A[20],B[20];
int main()
{
 int n;
 scanf("%d",&n);
 while(n--)
 {
 int sum=0;
 scanf("%s%s",A,B);
 for(char* p=A;*p;p++)
  for(char* q=B;*q;q++)
   sum+=(*p-'0')*(*q-'0');
 printf("%d\n",sum);
 }
}       


//运用字符,极大的节省了内存。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值