【PAT】【Advanced Level】1002. A+B for Polynomials (25)

1002. A+B for Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
原题链接:

https://www.patest.cn/contests/pat-a-practise/1002


思路:

map映射,同时记录下表个数,同时相加相同的下标

最后整理,输出


坑点:

多项式系数为0的时候要省去。


教训:

看题不细

忽略了系数为0的情况


CODE:

#include<iostream>
#include<cstring>
#include<string>
#include<map>
#include<vector>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;
//计算后多项式系数为0的情况。。。
//多项式。。
map<int,double> sl;
int _index[21];
bool k[1001];

bool cmp(int a,int b)
{
    return a>b;
}

int main()
{
    memset(k,0,sizeof(k));
    int num=0;
    for (int i=0;i<2;i++)
    {
        int n;
        cin>>n;
        for (int j=0;j<n;j++)
        {
            int a;
            double b;
            cin>>a>>b;
            if (k[a]!=0)
            {
                sl[a]+=b;
            }
            else
            {
                _index[num]=a;
                num++;
                sl[a]=b;
                k[a]=1;
            }
        }
    }
    sort(_index,_index+num,cmp);
    int nuum=num;
    for (int i=0;i<num;i++)
        if (fabs(sl[_index[i]]-0)<0.05) nuum--;
    cout<<nuum;
    for (int i=0;i<num;i++)
    {
        if (fabs(sl[_index[i]]-0)>=0.05)
            printf(" %d %.1lf",_index[i],sl[_index[i]]);
    }
    return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值