PAT甲级题库(2)1002 A+B for Polynomials (25 分)

本文介绍了PAT甲级题库中的1002题,即如何计算两个多项式的和。文章详细阐述了计算思路,包括创建结构体存储多项式项,比较指数并合并同类项,以及处理指数从高到低的过程。同时,作者指出了在处理过程中需要注意的陷阱,如删除容器中的元素时可能导致的迭代器失效问题,并提醒在C++中保留小数位数的方法。
摘要由CSDN通过智能技术生成

题目

1002 A+B for Polynomials (25 分)
This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 aN1 N2 aN2 … NK aNK

where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N K<⋯<N2<N1≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2

思路

该题目要求计算多项式的加法,首先第一眼想到的就是必须要核对两个多项式指数相同的项,然后再计算该项的系数相加得数以得到合并同类项后的值。同时不要忽略题目中输入都是有规律的,指数必须由高到低。而且指数的范围在1到1000之间。
1)先声明一个结构体存储多项式每一项的内容(指数,系数)
2)输入两个多项式,从两个多项式的首个元素中比较出指数最大是多少max
3)将指数从i=max到0开始遍历,查看多项式1和多项式2中是否有=i的项,有的话拿出这两项合并或者拿出其中一项,或者不做处理继续处理下一个。直到处理到i=0;
4)注意,处理完以后清楚得到的结果多项式中系数为0的这一项,这一步我答题的时候忽略了,有三个测试用例没有过,想了半天还。

代码

#include<iostream>
#include<list>
#include<iomanip>
using namespace std;
struct node
{
   
	int zhishu;
	double xishu;
};
int main()
{
   
	list<node> a;
	list<node> b;
	int ka;
	int kb;
	cin >> ka;
	node c;
	for (int i = 0; i < ka; i++)
	
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值