【PAT】【Advanced Level】1044. Shopping in Mars (25)

该博客探讨了在火星上使用钻石链进行支付的问题,其中支付金额可以通过切割钻石链来达到。文章介绍了如何在给定钻石价值链和需支付金额的情况下,找出所有可能的支付选项。当无法精确支付时,需要提供损失最小的解决方案。博主提供了两种方法,包括超时的暴力双重循环方法和高效的二分查找方法。文章最后给出了问题的输入输出规格,并附上了题目链接和思路解析。
摘要由CSDN通过智能技术生成

1044. Shopping in Mars (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5
原题链接:

https://www.patest.cn/contests/pat-a-practise/1044

https://www.nowcoder.com/pat/5/problem/4083

思路:

暴力思路:

双重循环

两个点超时

正解:

二分

CODE:

#include<iostream>
#include<cstdio>
#include<vector>
#define N 100010
using namespace std;

typedef struct S
{
	int l;
	int r;
};

int  sum[N];
vector<S> re;
int main()
{
	int n,s;
	cin>>n>>s;
	sum[0]=0;
	for (int i=1;i<=n;i++)
	{
		scanf("%d",&sum[i]);
		sum[i]=sum[i-1]+sum[i];		
	}
	int mi=0x7fffffff;
	for (int i=1;i<=n;i++)
	{
			int temp;
			int le=i;
			int ri=n;
			int mid;
			while (le<ri)
			{
				mid=(le+ri)/2;
				temp=sum[mid]-sum[i-1];
				if (temp>=s)
				{
					ri=mid;
				}
				else
				{
					le=mid+1;
				}
			}
			temp=sum[ri]-sum[i-1];
			if (temp>=s)
			{
				S tt;
				tt.l=i;
				tt.r=ri;
				if (temp<mi)
				{
					re.clear();
					re.push_back(tt);
					mi=temp;
				}
				else
				if (temp==mi)
				{
					re.push_back(tt);
				}
			}
			else
				break;
		}
	for (int i=0;i<re.size();i++)
	 	printf("%d-%d\n",re[i].l,re[i].r);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值