hdu1242优先队列+BFS

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29901    Accepted Submission(s): 10531


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

简单的优先队列+BFS题,,本来是个普通的广搜过程,但是,在x也就是守卫处,时间+2,这样就会导致守卫周围的时间不同,所以,利用优先队列找到最短时间,继续BFS就可以找到最短时间的路了。

#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>

#define MAX 205

using namespace std;

char map[MAX][MAX];
int visited[MAX][MAX];
int m,n;
int dir[4][2]={0,1,0,-1,1,0,-1,0};

typedef struct Node{
	int x;
	int y;
	int time;
}N;

struct cmp{
	bool operator ()(const N &a,const N &b)
	{
		if(a.time > b.time)
		{
			return true;
		}
		return false;
	}
};

bool able(int x,int y)
{
	if(x<0||y<0||x>m-1||y>n-1||map[x][y]=='#'||visited[x][y]!=0)
		return false;
	return true;
}

int bfs(int sx,int sy)
{
	priority_queue<Node,vector<Node>,cmp> q;
	Node a,b;
	a.x = sx;
	a.y = sy;
	a.time = 0;
	q.push(a);

	while(!q.empty())
	{
		a = q.top();
		q.pop();
		if(map[a.x][a.y]=='r')
			return a.time;
		for(int i=0;i<4;i++)
		{
			
			b.x = a.x+dir[i][0];
			b.y = a.y+dir[i][1];
			if(able(b.x,b.y))
			{
				if(map[b.x][b.y]=='x')
				{
					b.time = a.time+2;
				}
				else{
					b.time = a.time+1;
				}
				visited[b.x][b.y] = 1;
				q.push(b); 
			}
		}
	}
	return -1;
}

int main()
{
	
	int sx,sy;//设置起点坐标 
	int i,j;
	while(~scanf("%d%d",&m,&n))
	{
		for(i=0;i<m;i++)
		{
			scanf("%s",map[i]);
			for(j=0;j<n;j++)
			{
				if(map[i][j]=='a')
				{
					sx = i;
					sy = j;
				}
			}
		}
		memset(visited,0,sizeof(visited));
		visited[sx][sy] = 1;
		int res = bfs(sx,sy);
		if(res==-1)  
        printf("Poor ANGEL has to stay in the prison all his life.\n");  
        else  
        printf("%d\n",res);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值