POJ 1743 后缀数组 解题报告

Musical Theme

Description

A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1..88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this programming task is about notes and not timings.
Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it:
is at least five notes long
appears (potentially transposed – see below) again somewhere else in the piece of music
is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)
Transposed means that a constant positive or negative value is added to every note value in the theme subsequence.
Given a melody, compute the length (number of notes) of the longest theme.
One second time limit for this problem’s solutions!

Input

The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes.
The last test case is followed by one zero.

Output

For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.

Sample Input

30
25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
82 78 74 70 66 67 64 60 65 80
0

Sample Output

5

Hint

Use scanf instead of cin to reduce the read time.

【解题报告】
题意:有N(1 <= N <=20000)个音符的序列来表示一首乐曲,每个音符都是1..88范围内的整数,现在要找一个重复的主题。“主题”是整个音符序列的一个子串,它需要满足如下条件:
1.长度至少为5个音符。
2.在乐曲中重复出现。(可能经过转调,“转调”的意思是主题序列中每个音符都被加上或减去了同一个整数值)
3.重复出现的同一主题不能有公共部分。
即给出一串字符,求不重合的最长重复子串,并且长度大于要求的k值.
思路:将height值分组,然后记录在二分答案时满足height值>=p的sa[i]的最大最小值,然后要是最大值减去最小值会>=p,这就说明两个子串的lcp值>=p并且它们的坐标也相差>=p。
另外避免“转调”的影响,通过求相邻序列的差值解决。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std; 
#define maxx 20010

int n;
int wsf[maxx],wa[maxx],wv[maxx],wb[maxx],s[maxx];
int height[maxx],rank[maxx],sa[maxx];

int cmp(int *r,int a,int b,int k)
{
    return r[a]==r[b]&&r[a+k]==r[b+k];
}
void getsa(int *r,int *sa,int n,int m)
{
    int i,j,p,*x=wa,*y=wb;
    for(i=0;i<m;++i) wsf[i]=0;
    for(i=0;i<n;++i) wsf[x[i]=r[i]]++;
    for(i=1;i<m;++i) wsf[i]+=wsf[i-1];
    for(i=n-1;i>=0;--i) sa[--wsf[x[i]]]=i;
    for(j=1,p=1;p<n;j*=2,m=p)
    {
        for(p=0,i=n-j;i<n;++i) y[p++]=i;
        for(i=0;i<n;++i) if(sa[i]>=j)  y[p++]=sa[i]-j;
        for(i=0;i<n;++i) wv[i]=x[y[i]];
        for(i=0;i<m;++i) wsf[i]=0;
        for(i=0;i<n;++i) wsf[wv[i]]++;
        for(i=1;i<m;++i) wsf[i]+=wsf[i-1];
        for(i=n-1;i>=0;i--) sa[--wsf[wv[i]]]=y[i];
        swap(x,y);
        x[sa[0]]=0;
        for(i=1,p=1;i<n;++i)
        x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
    }
}
void getheight(int *r,int n)
{
    int i,j,k=0;
    for(i=1;i<=n;++i) rank[sa[i]]=i;
    for(i=0;i<n;++i)
    {
        if(k)k--;
        else k=0;
        j=sa[rank[i]-1];
        while(r[i+k]==r[j+k]) k++;
        height[rank[i]]=k;
    }
}
int deal(int n,int p)
{
    int minx=sa[0],maxx1=sa[0];
    for(int i=0;i<=n;++i)
    {
        if(height[i]>=p)
        {
            if(minx>sa[i]) minx=sa[i];
            if(maxx1<sa[i]) maxx1=sa[i];
            if(maxx1-minx>p) return 1;
        } 
        else minx=maxx1=sa[i];
    }
    return 0;
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n)
    {
        for(int i=0;i<n;++i)
        scanf("%d",&s[i]);
        for(int i=0;i<n-1;++i)
        {
            s[i]=s[i+1]-s[i]+90;  
        }
        n--;
        s[n]=0;
        getsa(s,sa,n+1,200);
        getheight(s,n);
        int l=0,r=n,coun=0;
        while(l<=r)                              
        {
            int mid=(l+r)>>1;
            if(deal(n,mid))
            {
                if(coun<mid) coun=mid;
                l=mid+1;
            }
            else r=mid-1;
        }
        if(coun<4) coun=0;                  
        else coun++;                   
        printf("%d\n",coun);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值