Cows
Description
Your friend to the south is interested in building fences and turning plowshares into swords. In order to help with his overseas adventure, they are forced to save money on buying fence posts by using trees as fence posts wherever possible. Given the locations of some trees, you are to help farmers try to create the largest pasture that is possible. Not all the trees will need to be used.
However, because you will oversee the construction of the pasture yourself, all the farmers want to know is how many cows they can put in the pasture. It is well known that a cow needs at least 50 square metres of pasture to survive.
Input
The first line of input contains a single integer, n (1 ≤ n ≤ 10000), containing the number of trees that grow on the available land. The next n lines contain the integer coordinates of each tree given as two integers x and y separated by one space (where -1000 ≤ x, y ≤ 1000). The integer coordinates correlate exactly to distance in metres (e.g., the distance between coordinate (10; 11) and (11; 11) is one metre).
Output
You are to output a single integer value, the number of cows that can survive on the largest field you can construct using the available trees.
Sample Input
4
0 0
0 101
75 0
75 101
Sample Output
151
【解题报告】
很套路的方法。
感觉自己的模板非常的清真,
网上的其他代码风格都是异端。
代码如下:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
#define N 10010
#define eps 1e-8
struct Point
{
double x,y;
Point(long double _ = .0,long double __ = .0):x(_),y(__) {}
friend bool operator <(const Point &a,const Point &b)
{return a.x<b.x||(a.x==b.y&&a.y<b.y);}
Point operator +(const Point &a)const
{return Point(x+a.x,y+a.y);}
Point operator -(const Point &a)const
{return Point(x-a.x,y-a.y);}
Point operator *(double a)const
{return Point(x*a,y*a);}
}p[N],ch[N];
int sign(double a){return(a>eps)?1:(a<-eps)?-1:0;}
double dot(Point a,Point b){return a.x*b.x+a.y*b.y;}
double cross(Point a,Point b){return a.x*b.y-a.y*b.x;}
int ComvexHull(Point* p,int n,Point* ch)
{
sort(p+1,p+n+1);
int m=0;
for(int i=1;i<=n;++i)
{
while(m>1&&cross(ch[m-1]-ch[m-2],p[i]-ch[m-2])<=0) m--;
ch[m++]=p[i];
}
int k=m;
for(int i=n-1;i>=1;--i)
{
while(m>k&&cross(ch[m-1]-ch[m-2],p[i]-ch[m-2])<=0) m--;
ch[m++]=p[i];
}
if(n>1) m--;
return m;
}
double PolygonArea(Point* p,int n)
{
double area=0;
for(int i=2;i<=n-1;++i)
area+=cross(p[i]-p[1],p[i+1]-p[1]);
return area/2;
}
int n;
int main()
{
scanf("%d",&n);
for(int i=1;i<=n;++i) scanf("%lf%lf",&p[i].x,&p[i].y);
int m=ComvexHull(p,n,ch);
printf("%d\n",(int)PolygonArea(ch,m)/50);
return 0;
}