hdu 1016 Prime Ring Problem (dfs)

题意:输入一个n(n<20),输出所有的素数环(相邻两个相加等于素数)。

Note: the number of first circle should always be 1.


Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int prime[41]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,0,1,0,0,0,0,0,1,0},n;
int vis[25],a[25];
void dfs(int x)
{int i;
    if(x==n&&prime[a[x-1]+a[0]]==1)
    {
        
        for(i=0;i<n-1;i++) printf("%d ",a[i]);
        printf("%d\n",a[n-1]);
    }
    else 
    {
        for(i=2;i<=n;i++)
        {
            if(!vis[i])
            {
                if(prime[a[x-1]+i])
                {
                    a[x]=i;
                    vis[i]=1;
                    x++;
                    dfs(x);
                    vis[i]=0;
                    x--;
                }
            }
        }
    }
}
int main()
{
    int cas=0;
    while(~scanf("%d",&n))
    {
        cas++;
        printf("Case %d:\n",cas);
        memset(a,0,sizeof(a));
        memset(vis,0,sizeof(vis));
        a[0]=1;
        dfs(1);
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值