1003. Emergency (25)【Dijkstra or DFS】

1003. Emergency (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4


自从退役后实在是好久没有敲题,感觉代码能力、数据结构、算法都忘记了[T T]

这题求最短路径,可以用Dijkstra,也可以用DFS,但输出确是:the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. 【坑点1】

而且,测试数据有C1==C2的情况,wa了第二个数据很久很久= =【坑点2】

上代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm> 
using namespace std;
 
const int maxnum = 505;
const int maxint = 0x3f3f3f3f;
 
int N,M,C1,C2;
void Dijkstra(int n, int v, int *dist, int *h,int *prev, int c[maxnum][maxnum],int hands[maxnum],int *pathcount)
{
    bool s[maxnum];    // 判断是否已存入该点到S集合中
    int i;
    for(i=0; i<n; ++i)
    {
        dist[i] = c[v][i];
        if(dist[i]==maxint)
        {
        	h[i] = hands[i];
		pathcount[i]=0;	
	}
        else
        {
        	h[i] = hands[v]+hands[i];
        	pathcount[i] = 1;
	}
        s[i] = 0;     // 初始都未用过该点
        if(dist[i] == maxint)
            prev[i] = -1;
        else
            prev[i] = v;
    }
    dist[v] = 0;
    s[v] = 1;
    pathcount[v] = 1;
    // 依次将未放入S集合的结点中,取dist[]最小值的结点,放入结合S中
    // 一旦S包含了所有V中顶点,dist就记录了从源点到所有其他顶点之间的最短路径长度
    for(i=2; i<=n; ++i)
    {
        int tmp = maxint;
        int u = v;
        // 找出当前未使用的点j的dist[j]最小值
        for(int j=0; j<n; ++j)
            if((!s[j]) && dist[j]<tmp)
            {
                u = j;              // u保存当前邻接点中距离最小的点的号码
                tmp = dist[j];
            }
        //if(tmp==maxint||u==C2) break;
        s[u] = 1;    // 表示u点已存入S集合中
        // 更新dist
        for(int j=0; j<n; ++j)
            if((!s[j]) && c[u][j]<maxint)
            {
                int newdist = dist[u] + c[u][j];
                int newh = h[u]+hands[j];
                if(newdist < dist[j])
                {
                	pathcount[j] = pathcount[u];
                    dist[j] = newdist;
                    h[j] = newh;
                    prev[j] = u;
                }
                else if(newdist == dist[j])
                {
                	pathcount[j] += pathcount[u];
                	if(newh>h[j])
                		h[j] = newh;
				}
            }
    }
}
int main()
{
	int dist[maxnum];     
	int prev[maxnum];    
	int h[maxnum];     
	int pathcount[maxnum];//用来记录所有最短路径的条数
	int hands[maxnum];
	int A[maxnum][maxnum];
	memset(hands,0,sizeof(hands));
	memset(A,0,sizeof(A));
	while(~scanf("%d%d%d%d",&N,&M,&C1,&C2))
	{
		int i,j;
		for(i=0;i<N;i++)
		{
			for(j=0;j<N;j++)
			{
				A[i][j]=maxint;
			}
		}
		for(i=0;i<N;i++)
		{
			scanf("%d",&hands[i]);
		}
		int a,b,c;
		for(i=0;i<M;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			A[a][b]=c;A[b][a]=c;
		}
		for(i=0;i<N;i++) 
		{
			dist[i]=maxint;
		}
		Dijkstra(N, C1, dist, h,prev, A,hands,pathcount);
		printf("%d %d\n",pathcount[C2],h[C2]);
	}
	return 0;
}

终于来贴DFS的代码了,看着大牛的打完,感觉吧,看完代码能理解,但是搁自己就敲不出DFS,天哪,谁来教教我!!

稍微说说对DFS的想法,首先要明确返回的条件是什么(这里是等于终点的时候),其次,如果有位置标记的话,返回的什么时候取消标记(这里是那个s数组,只是对于取消 标记是在循环外我有点蒙蔽,有人教教我就好了!先谢谢您!)

上代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm> 
using namespace std;
 
const int maxnum = 505;
const int maxint = 0x3f3f3f3f;
 
int N,M,C1,C2;
int A[maxnum][maxnum];
int hands[maxnum];
int mindist = maxint;
int maxhand = 0;
int cnt = 0;
int s[maxnum];
void dfs(int v,int dist,int hand)
{
	if(v==C2)
	{
		if(dist<mindist)
		{
			cnt=1;
			mindist = dist;
			maxhand = hand;
		}
		else if(dist == mindist)
		{
			cnt++;
			if(hand>maxhand)
			maxhand = hand;
		}
		return;
	}
	s[v]=1;
	int i,j;
	for(i=0;i<N;i++)
	{
		if((!s[i])&&A[v][i]>0)
			dfs(i,dist+A[v][i],hand+hands[i]);
	}
	s[v]=0;
}
int main()
{
	while(~scanf("%d%d%d%d",&N,&M,&C1,&C2))
	{
		int i,j;
		memset(s,0,sizeof(s));
		for(i=0;i<N;i++)
		{
			for(j=0;j<N;j++)
			A[i][j]=-1;
		}
		for(i=0;i<N;i++)
		{
			scanf("%d",&hands[i]);
		}
		int a,b,c;
		for(i=0;i<M;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			A[a][b]=c;A[b][a]=c;
		}
		dfs(C1,0,hands[C1]);
		printf("%d %d\n",cnt,maxhand);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值