hdu4488 Faulhaber’s Triangle(模拟)

Faulhaber’s Triangle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 124    Accepted Submission(s): 55


Problem Description
The sum of the m th powers of the first n integers
S(n,m) = SUM ( j= 1 to n)( j m)

Can be written as a polynomial of degree m+1 in n:

S(n,m) = SUM (k = 1 to m+1)(F(m,k) *n k)

Fo example:



The coefficients F(m,k) of these formulas form Faulhaber‘s Tr angle:


where rows m start with 0 (at the top) and columns k go from 1 to m+1

Each row of Faulhaber‘s Tr angle can be computed from the previous row by:

a) The element in row i and column j ( j>1) is (i/j )*(the element above left); that is:
F(i,j ) = (i/j )*F(i-1, j-1)
b) The first element in each row F(i,1) is chosen so the sum of the elements in the row is 1 

Write a program to find entries in Faulhaber‘s Tr angle as decimal f actions in lowest terms 
 

Input
The first line of input contains a single integer P, (1 <= P <= 1000), which is the number of data sets that follow. Each data set should be processed identically and independently 

Each data set consists of a single line of input consisting of three space separated decimal integers The first integer is the data set number. The second integer is row number m, and the third integer is the index k within the row of the entry for which you are to find F(m, k), the Faulhaber‘s Triangle entry (0 <= m <= 400, 1 <= k <= n+1).
 

Output
For each data set there is a single line of output. It contains the data set number, followed by a single space which is then followed by either the value if it is an integer OR by the numerator of the entry, a forward slash and the denominator of the entry. 
 

Sample Input
  
  
4 1 4 1 2 4 3 3 86 79 4 400 401
 

Sample Output
  
  
1 -1/30 2 1/3 3 -22388337 4 1/401
 

Source

题目大意:给出自然数幂和的系数矩阵公式,要求输出某个系数。

题目分析:公式给了,直接模拟输出即可。因为是分数表示的,所以用一个二维结构体存储每个数即可。

稍微细心点即可。

详情请见代码:

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<cctype>
#include<map>
#include<set>
#include<queue>
#include<vector>

using namespace std;
const int N = 405;
const int INF = 0x3f3f3f3f;
const double eps = 1e-5;
const double PI = acos(-1.0);
typedef __int64 ll;

struct node
{
    bool sig;
    ll fz,fm;
}lcm[N][N];

ll gcd(ll m,ll n)
{
    while(n)
    {
        ll tmp = m % n;
        m = n;
        n = tmp;
    }
    return m;
}

int main()
{
    int t,i,j,cas;
    int m,k;
    lcm[0][1].sig  = true;
    lcm[0][1].fm = lcm[0][1].fz = 1;
    for(i = 1;i <= 400;i ++)
    {
        for(j = 2;j <= i + 1;j ++)
        {
            lcm[i][j].sig = lcm[i - 1][j - 1].sig;
            lcm[i][j].fz = i * lcm[i - 1][j - 1].fz;
            lcm[i][j].fm = j * lcm[i - 1][j - 1].fm;
            ll tmp = gcd(lcm[i][j].fm,lcm[i][j].fz);
            lcm[i][j].fm /= tmp;
            lcm[i][j].fz /= tmp;
        }
        ll tfz = 1;
        ll tfm = 1;
        bool sig = true;
        for(j = 2;j <= i + 1;j ++)
        {
            if(sig)
            {
                if(lcm[i][j].sig)
                    tfz = tfz * lcm[i][j].fm - tfm * lcm[i][j].fz;
                else
                    tfz = tfz * lcm[i][j].fm + tfm * lcm[i][j].fz;
            }
            else
            {
                if(lcm[i][j].sig)
                    tfz = -tfz * lcm[i][j].fm - tfm * lcm[i][j].fz;
                else
                    tfz = -tfz * lcm[i][j].fm + tfm * lcm[i][j].fz;
            }
            if(tfz > 0)
                sig = true;
            else
            {
                tfz = -tfz;
                sig = false;
            }
            tfm = tfm * lcm[i][j].fm;
            ll tmp = gcd(tfz,tfm);
            tfz /= tmp;
            tfm /= tmp;
        }
        lcm[i][1].sig = sig;
        lcm[i][1].fm = tfm;
        lcm[i][1].fz = tfz;
    }
    scanf("%d",&t);
    while(t --)
    {
        scanf("%d%d%d",&cas,&m,&k);
        printf("%d ",cas);
        if(lcm[m][k].fz == 0)
            printf("0\n");
        else
        {
            if(lcm[m][k].sig == false)
                putchar('-');
            if(lcm[m][k].fm == 1)
                printf("%I64d\n",lcm[m][k].fz);
            else
                printf("%I64d/%I64d\n",lcm[m][k].fz,lcm[m][k].fm);
        }
    }
    return 0;
}//140MS	3492K

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值