hdu 4488 Faulhaber’s Triangle

44 篇文章 0 订阅

Faulhaber’s Triangle

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 152 Accepted Submission(s): 74


Problem Description
The sum of the m th powers of the first n integers
S(n,m) = SUM ( j= 1 to n)( j m)

Can be written as a polynomial of degree m+1 in n:

S(n,m) = SUM (k = 1 to m+1)(F(m,k) *n k)

Fo example:



The coefficients F(m,k) of these formulas form Faulhaber‘s Tr angle:


where rows m start with 0 (at the top) and columns k go from 1 to m+1

Each row of Faulhaber‘s Tr angle can be computed from the previous row by:

a) The element in row i and column j ( j>1) is (i/j )*(the element above left); that is:
F(i,j ) = (i/j )*F(i-1, j-1)
b) The first element in each row F(i,1) is chosen so the sum of the elements in the row is 1

Write a program to find entries in Faulhaber‘s Tr angle as decimal f actions in lowest terms

Input
The first line of input contains a single integer P, (1 <= P <= 1000), which is the number of data sets that follow. Each data set should be processed identically and independently

Each data set consists of a single line of input consisting of three space separated decimal integers The first integer is the data set number. The second integer is row number m, and the third integer is the index k within the row of the entry for which you are to find F(m, k), the Faulhaber‘s Triangle entry (0 <= m <= 400, 1 <= k <= n+1).

Output
For each data set there is a single line of output. It contains the data set number, followed by a single space which is then followed by either the value if it is an integer OR by the numerator of the entry, a forward slash and the denominator of the entry.

Sample Input
  
  
4 1 4 1 2 4 3 3 86 79 4 400 401

Sample Output
  
  
1 -1/30 2 1/3 3 -22388337 4 1/401

Source

Recommend
liuyiding
就是个模拟题很水,不解释!
#include <iostream>
#include <stdio.h>
using namespace std;
__int64 prime[450][450][3];
__int64 gcd(__int64 a,__int64 b)
{
    if(a<0)
    a=-a;
    if(b<0)
    b=-b;
    if(b==0)
		return a;
   return gcd(b,a%b);
}
void init()
{
    int i,twogcd,j;__int64 temp[3];
    prime[0][1][0]=1;prime[0][1][1]=1;prime[0][1][2]=1;
    for(i=1;i<=410;i++)
    {
         for(j=2;j<=i+1;j++)
        {
            prime[i][j][0]=prime[i-1][j-1][0]*i;
            prime[i][j][1]=prime[i-1][j-1][1]*j;
            prime[i][j][2]=prime[i-1][j-1][2];
            if(prime[i][j][0]==0)
            {
                prime[i][j][0]=0;
                prime[i][j][1]=1;
                prime[i][j][2]=1;
                continue;
            }
            twogcd=gcd(prime[i][j][0],prime[i][j][1]);
			if(twogcd==0)
				continue;
			prime[i][j][0]/=twogcd;
            prime[i][j][1]/=twogcd;

        }
        temp[0]=1,temp[1]=1;temp[2]=1;
        for(j=2;j<=i+1;j++)
        {
            temp[0]=temp[0]*prime[i][j][1]-temp[1]*prime[i][j][0];
            temp[1]=temp[1]*prime[i][j][1];
            if(temp[0]<0)
			{
            temp[2]=-1;

			}
            else
            temp[2]=1;
            if(temp[0]==0)
            {
                temp[1]=1;temp[2]=1;
            }
            int twogcd=gcd(temp[0],temp[1]);
			if(twogcd==0)
				continue;
			temp[0]/=twogcd;
            temp[1]/=twogcd;
        }
        if(temp[0]==0)
        {
            prime[i][1][0]=0;
            prime[i][1][1]=1;
            prime[i][1][2]=1;
            temp[2]=1;
        }
        else if(temp[0]==temp[1])
        {
            prime[i][1][0]=1;
            prime[i][1][1]=1;
            prime[i][1][2]=1;
        }
        else{
            prime[i][1][0]=temp[0];
            prime[i][1][1]=temp[1];
            prime[i][1][2]=1;
            if(prime[i][1][0]<0)
            {

                prime[i][1][2]=-1;
            }
            int twogcd=gcd(prime[i][1][0],prime[i][1][1]);
			if(twogcd==0)
				continue;
			prime[i][1][0]/=twogcd;
            prime[i][1][1]/=twogcd;
		//	printf("%I64d %I64d %d  \n",prime[i][1][0],prime[i][1][1],i);
        }
    }
}
int main()
{
    int tcase,tt,m,k;
	init();
    scanf("%d",&tcase);
    while(tcase--)
    {
        scanf("%d%d%d",&tt,&m,&k);
        printf("%d ",tt);

        if(prime[m][k][0]==0)
            printf("0\n");
        else if(prime[m][k][0]==prime[m][k][1])
        {
            printf("1\n");
        }
        else if(prime[m][k][1]==1)
        {
            printf("%I64d\n",prime[m][k][0]);
        }
        else
            printf("%I64d/%I64d\n",prime[m][k][0],prime[m][k][1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值