[POJ][1002]487-3279

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3
 

这道题比较简单,简单说一下,首先读取输入,用string读很方便,然后依次判断是什么符号,注意这道题里面有一些无关符号出现,所以最好是判断这个字符在哪个范围里面,根据这个范围计算对应数字,最终得到号码列表,为了方便起见,我们直接使用algorithm里面的sort函数排序,然后查找重复的就很方便了。存电话号码的是int类型的数组

具体的方法是从下表为1的元素开始,每次比较当前数和前面的数是否相同,相同就说明有重复,数量+1,不相同就检查数量是否大于1,此时的数量实际上是前一个电话号码的数量,大于1则输出前一个号码和对应数量,然后置1,否则不用管,因为此时它一定是1。注意最后一个需要单独判断。

由于电话号码使用int存储,所以输出时需要注意格式,要把宽度定好,填充字符设为'0'

下面是AC代码

#include<iostream>
#include<string>
#include<algorithm>
#include<iomanip>
using namespace std;
int main()
{
    int d,len;
    cin>>d;
    string s;
    int* hm = new int[d];
    for(int i=0,j=0;i<d;++i,++j)
    {
        hm[j]=0;
        cin>>s;
        len=s.length();
        for(int i=0;i<len;++i)//这个地方是通过计算得出对应数字,加入电话号码
        {
            if('A'<=s[i] && s[i]<='P') hm[j]=10*hm[j]+(s[i]-'A')/3+2;
            else if('R'<=s[i] && s[i]<='Y') hm[j]=10*hm[j]+(s[i]-'A'-1)/3+2;
            else if('0'<=s[i] && s[i]<='9') hm[j]=10*hm[j]+s[i]-'0';
        }
    }
    sort(hm,hm+d);//排序
    cout<<setfill('0');//填充字符为'0',这是为了防止数字输出后前面的0被扔掉
    bool nodup=true;
    for(int i=1,num=1;i<d;++i)
    {
        if(hm[i-1]==hm[i])
        {
            ++num;
            nodup=false;
        }
        else if(num>1)
        {
            cout<<setw(3)<<hm[i-1]/10000<<'-'<<setw(4)<<hm[i-1]%10000<<' '<<num<<endl;
            num=1;
        }
        if(i==d-1 && num>1) cout<<setw(3)<<hm[i-1]/10000<<'-'<<setw(4)<<hm[i-1]%10000<<' '<<num<<endl;
    }
    if(nodup) cout<<"No duplicates."<<endl;//没有重复号码的输出
    delete[] hm;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值