POJ:Relatives(欧拉函数直接求法)

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
Output

For each test case there should be single line of output answering the question posed above.
Sample Input

7
12
0
Sample Output

6
4
对欧拉函数不理解的话可以看着两个博客先学习下:
1.欧拉函数及其证明
https://blog.csdn.net/orange1710/article/details/81459362
2.【算法】欧拉函数——小于n的数中与n互质数的数目
https://blog.csdn.net/orange1710/article/details/81459451
代码如下:

#include <iostream>
#include <cstdio>
typedef long long ll;
ll n;
using namespace std;
void eular_Orz(ll a)
{
long long res,b;
res = a;
b = a;
for(int i=2;i*i<a;i++)
{
    if(a%i==0)
        res = res/i*(i-1);
    while(a%i==0) 
        a /= i; 
}
if(a>1) res = res/a*(a-1);
printf("%lld\n",res);
}

int main()
{
while(scanf("%lld",&n) && n)
    eular_Orz(n);   
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值