01背包问题的小改--结合概率

A - Robberies

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this. 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

小伙子抢劫银行,妈妈设指标,从法律的角度说。。。好了回归正题,这道题目主要思想就是动态规划,只不过将weight(volumn)改成了被police抓到的概率,只要不超过妈妈设置的概率就好了,然后抢到的钱其实就是value,那么方程就是dp[j]=max(dp[j],dp[j-m[i]]*p[i]),这里有个概率的问题,是高中知识,就是被抓的概率是p1,p2,p3,….pn;我们在考虑时要从反面思考,考虑1-pi,即不被抓到的概率,用互斥事件来处理。这样子才不会少情况。想啊,随着投银行的树木的增加,被捉到的概率是逐渐增加的,这样一想,没问题,这是注意点,还有就是开dp[]数组是要开到10010,的大小,因为银行最大金额是100 *100;这和一维的01背包问题类似,用背包容量做为dp数组的下标,其实,用value做下标也可以。
代码如下:

#include <iostream>
#include <cstdlib>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;
double dp[10010];
double p[105];
int m[105];
int main(){
    int t;
    cin>>t;
    while(t--){
        memset(p,0,sizeof(p));
        memset(m,0,sizeof(m));
        memset(dp,0,sizeof(dp));
        double plimit;
        int i, j, n, money=0;
        cin>>plimit>>n;
        for(i=1;i<=n;i++)
            cin>>m[i]>>p[i];
        for(i=1;i<=n;i++)
            money+=m[i];
        for(i=1;i<=n;i++)
            p[i]=1-p[i];
        dp[0]=1;

        for(i=1;i<=n;i++){
            for(j=money;j>=m[i];j--){
                    dp[j]=max(dp[j],dp[j-m[i]]*p[i]);


            }
        }
        for(j=money;j>=0;j--){
            if(dp[j]>1-plimit){
                cout<<j<<endl;
                break;
            }
        }
    }
    return 0;
}

今天自行车头的轴承坏了,只能走直线,我滴个神啊!!!努力总有回报,走回去困高啦!!!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值