1014 Waiting in Line (30分)

1014 Waiting in Line (30分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.

At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

没啥技术含量的,就是模拟时间。

注意的坑点是 五点时还在队列中的人仍然要继续服务完成,也就是说结束时间可能会超过5点。5点停止进入队列而已,并非停止提供已在队列中的人的服务。

#include<iostream>
#include<vector>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<map>
#include<queue>
#include<stack>
using namespace std;
int n,m,k,q;
int que[1000];
queue<int> v[20];
queue<int> peo[20];

string printtime(int mi)
{
//    if(mi>(17-8)*60)
//        return "Sorry";
    int beg = 480;
    int now = 0;
    now = beg+mi;
    int hour = now/60;
    int minu = now%60;
    string timenow = "";
    if(hour<10)
    {
        timenow="0";
    }
    char chhour[10];
    sprintf(chhour,"%d",hour);
    //cout<<"hour"<<chhour<<endl;
    timenow.append(chhour);
    timenow.append(":");

    if(minu<10)
    {
        timenow+="0";
    }
    char chmin[10];
    sprintf(chmin,"%d",minu);
    //cout<<"min"<<minu<<endl;
    timenow.append(chmin);
    //timenow+=std::to_string(minu);
    //cout<<timenow<<"<----timenow";
    return timenow;
}



int main()
{
    //printtime(6);

    int min[1000];
    int tneed[1000];
    memset(tneed,0,sizeof(tneed));
    cin>>n>>m>>k>>q;
    for(int i=0; i<k; i++)
        scanf("%d",&min[i]);
    int t=0;
    for(int i=0; i<m; i++)
    {
        for(int j=0; j<n; j++)
        {
            if(t<k)
            {
                v[j].push(min[t++]);
                peo[j].push(t);
               // cout<<min[t]<<"  ==:"<<endl;
            }

        }
    }

    for(int i=1; ; i++)
    {
        int emptynum = 0;
        for(int j=0;j<n;j++)
        {
            if(v[j].empty())
            {
                emptynum++;
            }
        }
        if(emptynum==n)
        break;
        for(int j=0; j<n; j++)
        {
            if(v[j].empty())continue;
            v[j].front() = v[j].front()-1;
           //cout<<"after -1 j front"<<j<<"  :  "<<v[j].front()<<endl;
            int temp = v[j].front();

            if(temp == 0)
            {
                //delete old one
                v[j].pop();
                int peonum = peo[j].front();
                tneed[peonum] = i;
               // cout<<"peonum:  "<<peonum<<"i :"<<i<<endl;
                peo[j].pop();
                // add new one
                if(t<k && i<=540)
                {
                    v[j].push(min[t++]);
                    peo[j].push(t);
                    //cout<<"push one people"<<t<<"min is"<<min[t-1]<<"  i = "<<i<<endl;
                }

            }
        }
    }

    for(int i=0; i<q; i++)
    {
        scanf("%d",&que[i]);
    }
//    for(int i=1; i<=k; i++)
//    {
//        cout<<"  order is "<<tneed[i]<<endl;
//    }
    for(int i=0; i<q; i++)
    {
        //cout<<"res is"<<tneed[que[i]]-min[que[i]-1]<<" need time:"<<min[que[i]-1]<<endl;
        if(tneed[que[i]] && (tneed[que[i]]-min[que[i]-1])<540)
        cout<<printtime(tneed[que[i]])<<endl;
        else
        cout<<"Sorry"<<endl;
    }
    return 0;
}



//2 2 7 5
//1 2 6 4 3 536 2
//3 4 5 6 7

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值