1014 Waiting in Line (30 分)

1014 Waiting in Line (30 分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.

At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

 Java的代码是时间超时的最后一个我不知道怎么让他过。。。。所以!
最后一个测试点我写超时!

代码:

import java.util.Scanner;
import java.util.TreeMap;
import java.awt.List;
import java.util.ArrayList;
import java.util.Comparator;
import java.util.LinkedList;
import java.util.Queue;
import java.util.Map;
public class Main {
	static Scanner sc = new Scanner(System.in);
	static class node{
		public int id,waittime;
		public int beginntime,enddtime,flag;
	}
	public static void main(String[] args) {
		int n, m ,peo, k;
		n = sc.nextInt();
		m = sc.nextInt();
		peo = sc.nextInt();
		k = sc.nextInt();
		node min[] = new node [peo + 1];
		for(int i = 1; i <= peo; i++)
		{
			node gg = new node();
			gg.waittime = sc.nextInt();
			gg.id = i;
			gg.flag = 0;
			min[i] = gg;
		}
		ArrayList<Queue> lst = new ArrayList<Queue>();
		for(int i = 0; i < n; i++)
			lst.add(new LinkedList<node>());
		int len[] = new int[peo + 1];
		int now = 1;
		
		for(int i = 1; i <= m; i ++ )
		{
			for(int j = 1; j <= n; j++)
			{
				if(now <= peo)
				{
					min[now].beginntime = len[j-1];
					min[now].enddtime = len[j-1] + min[now].waittime;
					if(min[now].beginntime >= 540)
						min[now].flag = 1;
					lst.get(j-1).add(min[now]);
					len[j-1] += min[now].waittime;
				}
				++now;
			}
		}
		while(now <= peo) //此刻看下这个人是否小于....找到当前最短时间
		{
			int dd = Integer.MAX_VALUE, u = -1;
			for(int i = 0 ; i < n; i++)
			{
				node gg = (node) lst.get(i).element();
				if(gg.enddtime < dd)
				{
					dd = gg.enddtime;
					u = i;//表示是哪个
				}
			}//遍历一下找到最小的那个
			
			lst.get(u).poll();//把第一个元素扔了
			min[now].beginntime = len[u];
			if(len[u] >= 540)
				min[now].flag = 1;//表示sorry
			min[now].enddtime = min[now].beginntime + min[now].waittime;
			len[u] = min[now].enddtime;//更新后
			lst.get(u).add(min[now]);
			now ++;
		}
		for(int i = 1; i <= k; i++)
		{
			int id = sc.nextInt();
			if(min[id].flag == 1)
				System.out.println("Sorry");
			else
				System.out.printf("%02d:%02d\n",min[id].enddtime / 60 + 8, min[id].enddtime % 60);
		}
	}
}

附上觉得写的不错的博客:https://blog.csdn.net/liuchuo/article/details/54561626

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值