POJ 3268 Silver Cow Party

题目描述:
有N(1≤N≤1000)个农场,编号为1~N,每个农场有一头奶牛。这些奶牛将参加在#X(1≤X
≤N)号农场举行的派对。这N 个农场之间有M(1≤M≤100,000)条单向路,通过第i 条路将需要
花费Ti(1≤Ti≤100)单位时间。
每头奶牛必须走着去参加派对。派对开完以后,返回到它的农场。每头奶牛都很懒,所以总
是选择一条具有最短时间的最优路。每头奶牛的往返路线是不一样的,因为所有的路都是单向的。

对所有的奶牛来说,花费在去派对的路上和返回农场的最长时间是多少?


输入描述:
测试数据的格式为:第1 行为3 个整数N、M 和X;第2~M+1 行描绘了M 条单向路,其中
第i+1 描绘了第i 条路,为3 个整数Ai、Bi 和Ti,表示这条路是从Ai 农场通往Bi 农场,所需时间

为Ti。


输出描述:

输出占一行,为所有奶牛必须花费的最大时间。

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

个人SPFA的第二题......对最短路有一定理解时,学新的算法也是很舒服的.......

本题需要求两次最短路,一次正向,一次反向...所以两次SPFA......感叹SPFA的高效啊~~~

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <vector>
#include <queue>
# define MAX 1005
# define INF 0x7FFFFFFF
using namespace std;
struct node
{
    int e;
    int value;
};
int n,m,visit[MAX];

void spfa(int v0,int dist[],vector<node> edge[])//模版spfa
{
    int i;
    queue<int> q;
    for(i=1; i<=n; i++)
        dist[i] = INF;
    dist[v0] = 0;
    q.push(v0);
    visit[v0] = 1;
    while(! q.empty())
    {
        int t = q.front();
        q.pop();
        visit[t] = 0;
        for(i=0; i<edge[t].size(); i++)
        {
            int e = edge[t][i].e;
            int value = edge[t][i].value;
            if(dist[e] > dist[t] + value)
            {
                dist[e] = dist[t] + value;
                if(visit[e] == 0)
                {
                    q.push(e);
                    visit[e] = 1;
                }
            }
        }
    }
}

int main()
{
    int i,x,a,b,c;
    int dist1[MAX],dist2[MAX];//正反两次的最短距离
    vector<node> edge1[MAX];//正向边
    vector<node> edge2[MAX];//反向边
    scanf("%d%d%d",&n,&m,&x);
    node tt;
    for(i=0; i<m; i++)//构造正反图
    {
        scanf("%d%d%d",&a,&b,&c);
        tt.e = b;
        tt.value = c;
        edge1[a].push_back(tt);
        tt.e = a;
        tt. value = c;
        edge2[b].push_back(tt);
    }
    //两次SPFA
    memset(visit,0,sizeof(visit));
    spfa(x,dist1,edge1);
    memset(visit,0,sizeof(visit));
    spfa(x,dist2,edge2);
    int max = -1;
    for(i=1; i<=n; i++)//选出最大值
    {
        if(max < dist1[i] + dist2[i] && dist1[i] != INF && dist2[i] != INF)
            max = dist1[i] + dist2[i];
    }
    printf("%d\n",max);
    return 0;
}

加油............................................!!!


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值