搜索1(广度优先)Red and Black

Red and Black

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 13
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. '.' - a black tile '#' - a red tile '@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13

  
  

我理解的搜索就是从一个起始点按某种规律对地图上的每个可检索点进行判断(规律如:按前后左右走),直到满足情况时跳出或全部检索完毕;

下面是我这题的代码:

#include<iostream>
#include<string>
#include<string.h>
#include<sstream>
#include<queue>
using namespace std;
struct node
{
    int x,y;
}s;    //s为起点
int n,m,h;
char a[20][20];  //地图
int dir[4][2]={{1,0},{0,1},{0,-1},{-1,0}};//走的方向
void bfs()
{
    queue<node>q;
    node t,x1;
    q.push(s);
    while (!q.empty())
    {
        t=q.front();
        q.pop();
        for (int i=0;i<4;i++)    //4个方向搜索,满足条件入队
        {
            x1.y=t.y+dir[i][1];
            x1.x=t.x+dir[i][0];
            if(x1.x>=0&&x1.x<m&&x1.y>=0&&x1.y<n&&a[x1.x][x1.y]=='.')  
            {
                h++;
                a[x1.x][x1.y]='#';   //检索的标记防止多次计算
                q.push(x1);
            }
        }
    }
    cout<<h<<endl;
}
int main()
{
    int i,j;
    while (cin>>n>>m,n+m)
    {
        h=1;
        for (i=0;i<m;i++)   //输入地图找到起点
            for (j=0;j<n;j++)
            {
                cin>>a[i][j];
                if (a[i][j]=='@')
                {
                    s.x=i;
                    s.y=j;
                }
            }
        bfs();
    }
    return 0;
}



  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值