简单dp求最大子序列

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
 
 
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
 
 
Case 1: 14 1 4 Case 2: 7 1 6

这是一个求最大子序列的题目,转移状态为大于0时加不加当前这个单序列,如果子序列全部小于0,

则寻找最大的那个单序列。

代码如下:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
int a[100005];
int main(){
    int t;
    cin>>t;
    int n=t;
    while(t--){
        memset(a,0,sizeof(a));
        int b;
        cin>>b;
        for(int i=1;i<=b;i++){
            cin>>a[i];
        }
        ll ans=a[1],sum=0;
        int begin=1,start=0,end=1;
        for(int i=1;i<=b;i++){
            sum+=a[i];
             if(sum>ans){
                ans=sum;
                begin=start+1;
                end=i;
            }
            //当和小于0时不取
            if(sum<0){
                sum=0;
                start=i;
            }
        }
        cout<<"Case "<<n-t<<":"<<endl;
        cout<<ans<<" "<<begin<<" "<<end<<endl;
        if(t>0) cout<<endl;
    }
    return 0;
}
注意:ans初值为第一个数(满足全部小于0时取一个最大的),begin初值为1.

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值