POJ 2352 Stars

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 48138 Accepted: 20778

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1

0

如果不懂树状数组,可以参考博客:http://blog.csdn.net/passer__/article/details/76653144

题意:给你很多的点,这些点代表星星的位置,在一个二维坐标系上,第一个是X,第二个是Y,然后求每个星星的等级,

它的等级取决于它的左下有多少星星满足(x<=x0 && y<=y0);最后从等级1开始输出,最高是n,每个人最低是1(因为他自己本身)

树状数组,输入的时候开始建立。

#include<stdio.h>
#include<string.h>
int a[15100];//记录LV 为0~15000都有几个星星 (星星的个数) 
int c[32100];//树状数组 
int lowbit(int x)
{
	return x&(-x);
}
int sum(int x)
{
	int sum=0;
	while(x>0)
	{
		sum=sum+c[x];
		x=x-lowbit(x);
	}
	return sum;
}
void sum1(int x)
{
	while(x<=32010)
	{
		c[x]++;//管理的星星+1 
		x=x+lowbit(x);
	}
} 
int main()
{
	int n,x,y;
	while(scanf("%d",&n)!=EOF)
	{
		memset(a,0,sizeof(a));//清空记录星星个数的数组
		memset(c,0,sizeof(c)); 
		int t=n;
		while(t--)
		{
			scanf("%d%d",&x,&y);
			a[sum(++x)]++;  	 //从1开始  因为树状数组是从1开始的 输入的点可能是0 所有加1处理 
			sum1(x);//将此点之后所有的父亲以上的节点 +1; 
		}
		for(int i=0;i<n;i++)
			printf("%d\n",a[i]);
	}
	return 0;
 } 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值