C语言输出出生年月(数组)东大1342

东北大学在线编程社区problem1342
题目描述:
从键盘输入18位身份证号(字符数组),输出出生年月(整型)。
输出格式"%d-%d"
输入不是18位,则输出"input error"

输入样例:37050520000426205X
输出样例:2000-4

//该代码使用Microsoft Visual Stdio2019编写
#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
#include <string.h>

int main(void)
{
	char code[20];
	int n, year, month;
	gets(code);
	n = strlen(code);
	if (n == 18) {
		year = (code[6] - 48) * 1000 + (code[7] - 48) * 100 + (code[8] - 48) * 10 + (code[9] - 48) * 1;
		month = (code[10] - 48) * 10 + (code[11] - 48) * 1;
		printf("%d-%d", year, month);
	}
	else
		printf("input error");
	return 0;
}

原题有使用二维数组的提示,但是作者怕麻烦就没有用。

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Patrick_Zhu_NEUer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值