JAVA大数求余 Basic remains(POJ 2305)

Basic remains(POJ 2305)
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2863 Accepted: 1169

Description

Given a base b and two non-negative base b integers p and m, compute p mod m and print the result as a base b integer. p mod m is defined as the smallest non-negative integer k such that p = a*m + k for some integer a.

Input

Input consists of a number of cases. Each case is represented by a line containing three unsigned integers. The first, b, is a decimal number between 2 and 10. The second, p, contains up to 1000 digits between 0 and b-1. The third, m, contains up to 9 digits between 0 and b-1. The last case is followed by a line containing 0.

Output

For each test case, print a line giving p mod m as a base-b integer.

Sample Input

2 1100 101
10 123456789123456789123456789 1000
0

Sample Output

10
789

CODE:


//
import java.util.*;
import java.math.*;
import java.io.*;
public class HDOJ_1000 {
public static void main(String[] args)
{
BigInteger p,m,mul,N;
int i,len;
int n;
String  a,b;


Scanner cin=new Scanner(System.in);
while(cin.hasNext())
{

n=cin.nextInt();
    if(n==0)
    break;
p=BigInteger.valueOf(0);
m=BigInteger.valueOf(0);
a=cin.next();
b=cin.next();
len=a.length();
mul=BigInteger.valueOf(1);

  N=BigInteger.valueOf(n);

for(i=len-1;i>=0;i--)
{
p=p.add(BigInteger.valueOf((a.charAt(i)-'0')).multiply(mul));
mul=mul.multiply(N);
}
len=b.length();
mul=BigInteger.valueOf(1);
for(i=len-1;i>=0;i--)
{
m=m.add(BigInteger.valueOf((b.charAt(i)-'0')).multiply(mul));
mul=mul.multiply(N);


}
System.out.println(p.mod(m).toString(n));





}
}

}



//








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值