POJ 2305 Basic remains(大数取模)(JAVA)

Basic remains

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 4076

 

Accepted: 1707

Description

Given a base b and two non-negative base b integers p and m, compute p mod m and print the result as a base b integer. p mod m is defined as the smallest non-negative integer k such that p = a*m + k for some integer a.

Input

Input consists of a number of cases. Each case is represented by a line containing three unsigned integers. The first, b, is a decimal number between 2 and 10. The second, p, contains up to 1000 digits between 0 and b-1. The third, m, contains up to 9 digits between 0 and b-1. The last case is followed by a line containing 0.

Output

For each test case, print a line giving p mod m as a base-b integer.

Sample Input

2 1100 101

10 123456789123456789123456789 1000

0

Sample Output

10

789

Source

Waterloo local 2003.09.20

 解题报告:以b进制输入p和m,求p模m的b进制结果 ,用Java写挺简单的

代码如下:

import java.util.Scanner;
import java.math.BigInteger;
public class Main{
    public static void main(String[] args){
        Scanner scan = new Scanner(System.in);
        BigInteger ans, p, m;
        int b;
        String str;
        while (scan.hasNextInt()){
            b = scan.nextInt();
            if (b == 0){
                break;
            }
            p = scan.nextBigInteger(b);
            m = scan.nextBigInteger(b);
            ans = p.mod(m);
            str = ans.toString(b);//将ans转化成b进制形式
            System.out.println(str);
        }
    }
}

转载于:https://www.cnblogs.com/lidaojian/archive/2012/05/25/2518361.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值