UVA 10892 LCM Cardinality

Question:
A pair of numbers has a unique LCM but a single number can be the LCM of more than one possible
pairs. For example 12 is the LCM of (1, 12), (2, 12), (3,4) etc. For a given positive integer N, the
number of different integer pairs with LCM is equal to N can be called the LCM cardinality of that
number N. In this problem your job is to find out the LCM cardinality of a number.
Input
The input file contains at most 101 lines of inputs. Each line contains an integer N (0 < N ≤ 2 ∗ 109
).
Input is terminated by a line containing a single zero. This line should not be processed.
Output
For each line of input except the last one produce one line of output. This line contains two integers
N and C. Here N is the input number and C is its cardinality. These two numbers are separated by a
single space.
Sample Input
2
12
24
101101291
0
Sample Output
2 2
12 8
24 11
101101291 5
题意大意:给你一个正整数n,让你找出LCM(a,b)=n的对数(a<=b).
思路:这题比较简单,只需要找出给出数n的因子即可,将其推入一个数组,再对数组进行操作,找出p[i]*p[j]/gcd(p[i],p[j])==n的对数
(http://acm.hust.edu.cn/vjudge/contest/121559#problem/D)

#include <iostream>
#include <cstdio>
#include <vector>
#include <cmath>
using namespace std;
typedef long long LL;
vector <LL> p;
LL gcd(LL a,LL b)
{
    if(b==0)
        return a;
    else return  gcd(b,a%b);
}
int main()
{
    LL n,num;
    while (1)
    {
        num=0;
        scanf("%lld",&n);
        if(n==0)
            break;
        for(LL i=1;i<=sqrt(n);i++)
        {
            if(i==sqrt(n))
                p.push_back(i);  //一个因子只需要推入一次即可,此操作避免重复重复推入一个因子
            else if(n%i==0)
            {
                p.push_back(i);
                p.push_back(n/i);
            }
        }
        for(int i=0;i<p.size();i++)
        {
            for(int j=i;j<p.size();j++)
            {
                if(p[i]*p[j]/gcd(p[i],p[j])==n)
                        num++;
            }
        }
        printf("%lld %lld\n",n,num);
        p.clear();
    }
    return 0;
}

这题不难,只要你敢想敢做就行,不要被题吓到,有时就是这么简单

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值