UVALive 2889 Palindrome Numbers

Question:
A palindrome is a word, number, or phrase that reads the same forwards as backwards. For example,
the name “anna” is a palindrome. Numbers can also be palindromes (e.g. 151 or 753357). Additionally
numbers can of course be ordered in size. The first few palindrome numbers are: 1, 2, 3, 4, 5, 6, 7, 8,
9, 11, 22, 33, …
The number 10 is not a palindrome (even though you could write it as 010) but a zero as leading
digit is not allowed.
Input
The input consists of a series of lines with each line containing one integer value i (1 ≤ i ≤ 2 ∗ 109
).
This integer value i indicates the index of the palindrome number that is to be written to the output,
where index 1 stands for the first palindrome number (1), index 2 stands for the second palindrome
number (2) and so on. The input is terminated by a line containing ‘0’.
Output
For each line of input (except the last one) exactly one line of output containing a single (decimal)
integer value is to be produced. For each input value i the i-th palindrome number is to be written to
the output.
Sample Input
1
12
24
0
Sample Output
1
33
151
题意大意:将回文数从大到小排列,1,2,3,4,5,6,7,8,9,11,22,,,,99,,,输入一个数n,让你输出第n大的回文数是多少。
思路:仔细找你会发现一位数和两位数的回文数都只有9个,三位数和四位数的回文数有90个,五位数和六位数的回文数有900个,以此类推。
(http://acm.hust.edu.cn/vjudge/contest/121559#problem/H)

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
    int n,i,j,t1,t2,t3;
    while (scanf("%d",&n),n)
    {
        i=9;j=1;
        while (1)
        {
            if(n<=i)
            {
                t1=j+n-1;   //此部分数位奇数位,设位数为n,先算出前面部分n/2+1位
                cout<<t1;
                t2=t1/10;
                while(t2)
                {
                    cout<<t2%10; // 再算出后面的n/2位
                    t2/=10;
                }
                break;
            }
            n-=i;
            if(n<=i)
            {
                t1=j+n-1;  //此部分数位偶数位,设位数为n,先算出前面部分n/2位
                cout<<t1;
                t2=t1;
                while(t2)
                {
                    cout<<t2%10;  // 再算出后面的n/2位
                    t2/=10;
                }
                break;
            }
            n-=i;
            i*=10;
            j*=10;

        }
        cout<<endl;

    }
    return 0;
}

体会:做题要善于总结规律,发现规律,千万不要嫌麻烦,多算几组可能就发现规律了。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值