HDU 1059 Dividing

Question
Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.

The last line of the input file will be 0 0 0 0 0 0''; do not process this line.
Output
For each colletcion, output
Collection #k:”, where k is the number of the test case, and then either Can be divided.'' orCan’t be divided.”.

Output a blank line after each test case.
Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
Sample Output
Collection #1:
Can’t be divided.

Collection #2:
Can be divided.
题目大意:给你6种数量6种价值的物品,问你是否能将他们价值均分
解题思路:这是一个背包问题,可以通过多重背包二进制优化解题
(http://acm.hust.edu.cn/vjudge/contest/125402#overview)

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int MAX=500000;
int a[10],dp[MAX],v;
void ZoroOne_Pack(int cost,int weight)   //01背包
{
    for(int i=v;i>=cost;i--)
        dp[i]=max(dp[i],dp[i-cost]+weight);
}
void Complete_Pack(int cost ,int weight)  //完全背包
{
    for(int i=cost;i<=v;i++)
        dp[i]=max(dp[i],dp[i-cost]+weight);
}
void Multi_Pack(int cost ,int weight,int amount)
{
    if(cost*amount>=v)
    {
        Complete_Pack(cost,weight);
        return ;
    }
    else    //二进制优化
    {
        int t=1;
        while (t<amount)
        {
            ZoroOne_Pack(t*cost,t*weight);
            amount-=t;
            t*=2;
        }
    }
    ZoroOne_Pack(amount*cost,amount*weight);
}
int main()
{
    int ncase=0;
    while(cin>>a[1]>>a[2]>>a[3]>>a[4]>>a[5]>>a[6],a[1]+a[2]+a[3]+a[4]+a[5]+a[6])
    {
        v=0;
        memset(dp,0,sizeof(dp));
        printf("Collection #%d:\n",++ncase);
        for(int i=1;i<=6;i++)
            v+=a[i]*i;
        if(v%2)
            printf("Can't be divided.\n");
        else
        {
            v/=2;   //对其总价值一般进行dp
            for(int i=1;i<=6;i++)
                Multi_Pack(i,i,a[i]);
            if(dp[v]==v)  //如果一半能放进价值为总价值一半的物品,则说明这些物品可以价值均分
                printf("Can be divided.\n");
            else
                printf("Can't be divided.\n");
        }
        printf("\n");  //此处注意有两个换行
    }
    return 0;
}

体会:学会了多重背包二进制优化,就不会再为了物品数量太多而超时。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值