Train Problem I(栈模拟)

题目描述:

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world v). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can’t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
在这里插入图片描述

输入描述:

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

输出描述:

The output contains a string “No.” if you can’t exchange O2 to O1, or you should output a line contains “Yes.”, and then output your way in exchanging the order(you should output “in” for a train getting into the railway, and “out” for a train getting out of the railway). Print a line contains “FINISH” after each test case. More details in the Sample Output.

输入样例:

3 123 321
3 123 312

输出样例:

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can’t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output “No.”.

//开始题意理解了挺久 想当然认为是两字符串顺序相反
思路:开两个字符数组a,b 先将a数组元素存入栈中 如栈顶元素按顺序与b数组元素相同 则出栈

#include<stdio.h>
char  a[10];//O1
char  b[10];//O2
char  c[10];//栈数组
int   d[20];//用来记录入栈、出栈操作
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        scanf("%s",a);
        scanf("%s",b);
        int top=0,j=0,i=0,flag=1,x=0;
        for(i=0;i<n;i++)
        {
            c[top++]=a[i];//先将a数组元素存入栈中
             d[x++]=0;//用0代表入栈
                if(c[top-1]==b[j])
                {
                    while(c[top-1]==b[j])//用栈顶元素与b数组元素比较 直到栈顶元素与b数组元素不相同
                    {
                      top--;//出栈
                      j++;
                     d[x++]=1;//用1代表出栈
                     if(top==0)
                        break;
                    }
                }
        }
        for(i=0;i<n;i++)//另一种情况就是两数组顺序相反
        {
          if(a[i]!=b[n-1-i])
            flag=0;
        }
        if(flag||top==0)
        {
         printf("Yes.\n");
         if(flag)
           { for(i=0;i<n;i++)
         {
           printf("in\n");
         }
         for(i=0;i<n;i++)
         {
          printf("out\n");
         }
           }
           else
           {
             for(i=0;i<x;i++)
             {
                if(d[i]==0)
                    printf("in\n");
                if(d[i]==1)
                    printf("out\n");
             }
           }
        }
        else
            printf("No.\n");
            printf("FINISH\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值