【贪心】POJ 3069 Saruman's Army

Saruman's Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12207 Accepted: 6140

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source



原理不是很难想,实现的时候注意一下细节就好。

题目大意
给你一系列点,让你标记其中的一些点,且在标记点R范围内的左右所有点都被能够被覆盖,问你最少需要多少点被标记才能覆盖所有点,且被标记点自身可以看作与被标记点自身距离为0的一个点。
分析
从左边第一个点考虑,它既然一定会被标记,那么它肯定在它右边某一个距离小于等于R的点的覆盖范围之内,那么我们只要向右前进R,找到第一个与左边点距离超过R的点,那么这个点的上一个点与左边的第一个点的距离就小于R,也就可以覆盖最左边的第一个点且保证R的利用最大,即保证最少标记点,这个超过R的点的上一个点就是我们应该找的标记点。我们记这个标记点为middle,那么middle点向右推进R,找到它可以覆盖最远的点,那么这个点后面的第一个点自然就是可以看成下一个标记点最左边的点,重复上述过程,直到所有点被覆盖即可。
一段话中这个点那个点好多....不知道有没有把大家绕晕......

附上AC代码
#include<stdio.h>
#include<algorithm>
using namespace std;
int poi[1006],num,r;

void solve(void)
{
    while(~scanf("%d%d",&r,&num)&&r!=-1&&num!=-1){

        for(int i = 0 ; i < num ; i++) scanf("%d",&poi[i]);

        sort(poi,poi+num);

        int i = 0,ans = 0;
        while(i<num){
            int left = poi[i];//当前最左边没有被覆盖的点
            while(poi[i]-left<=r) i++;//找到第一个大于覆盖范围的点
            int middle = poi[--i];//那么若标记上一个点就可以覆盖左边没有覆盖的点。
            while(poi[i]-middle<=r) i++;//找到最右边能覆盖到的极限,组后i的值就是新的最左边没有覆盖点的下标。
            ans++;
        }

        printf("%d\n",ans);

    }
}

int main(void)
{
    solve();

    return 0;
}









评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

两米长弦

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值