Android 解决因Android版本太低,导致Could not find class 错误的解决办法

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/pengguichu/article/details/78952074

近期项目在测试过程中,在Android 5.0版本的测试中(以前APP测试未出现),GreenDao 出现 Could not find class 'org.greenrobot.greendao.database.StandardDatabase'  错误

查阅资料后发现是Android 的4.4分包机制导致,也就是说当你的DEX文件方法超过65536后应用就已经饱满了。所以就会出现以上错误。

解决方法:

1.在grade 中引入 如图所示包 


2.在grade中设置  multiDexEnabled为true


3.将自己的Application类继承MultiDexApplication类,


4.实现attachBaseContext方法,初始化MultiDex.install

实现以上步骤之后就可以解决分包问题了,想要了解的更加具体可以看看这篇文章  Android 使用android-support-multidex解决Dex超出方法数的限制问题,让你的应用不再爆棚  讲解的很详细


展开阅读全文

没有更多推荐了,返回首页