ACdream 1125 ACFun

Description

As a former ACMer, "AC" is a special abbreviated word which can bring much pleasure to me. Sometimes it means everything. 
This problem is about "AC". 
One day, I write a long string S on the paper which contains "A" and "C". Now I want to find a lexicographic minimum string T satisfied that T is distinct with all substring of S.

Input

The first line of input file contains an integer T indicating the number of case. 
In each test case: 
Input a string S consist of "A" and "C". The length of S is not large than 100.

Output

For each test case: 
You should output the string T meet the condition.

Sample Input

1
ACAC

Sample Output

AA

自己写的略麻烦啊。。。

#include <stdio.h>
#include <string.h>
#define N 105
char a[N];
int b[N];

int main() {
	int n;
	scanf("%d\n", &n);
	while (n--) {
		gets(a);
		int t = 0;
		for (int i = 0; i < strlen(a); i++)
			if (a[i] == 'A')
				b[t++] = i;	
		int index = 0, max = 0;
		for (int j = 0; j < t; j++) {
			if (j == 0) {
				index++;
				max = index;
				continue;
			}
			if (b[j] == b[j-1] + 1) {
				index++;
				if (index > max)
					max = index;
			}
			else
				index = 1;
		}
		for (int i = 0; i <= max; i++)	
			printf("A");
		printf("\n");
	}
	return 0;
}


别人的:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define N 100
char str[N];

int main() {
	int n;
	scanf("%d", &n);
	while (n--) {
		gets(str);
		int len = strlen(str), index = 0, maxx = 0;
		for (int i = 0; i < len; i++) {
			if (str[i] == 'A')
				index++;
			else {
				maxx = max(index, max);
				index = 0;
			}
		}
		maxx = max(maxx, index);
		for (int i = 0; i <= maxx; i++)
			printf("A");
		printf("\n");
	}
	return 0;
}



1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值