OpenJudge-Mooc 2:A Knight's Journey(dfs)

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
输入
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
输出
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
样例输入
3
1 1
2 3
4 3
样例输出
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:

A1B3C1A2B4C2A3B1C3A4B2C4

/*
 * dfs、 注意要按照字典序来设置dir[8][2]..
*/
#include "iostream"
#include "cstring"
using namespace std;
int col, row;
int pathI[30], pathJ[30];
bool visited[27][27];
int dir[8][2] = { { -2,-1 },{ -2,1 },{ -1,-2 },{ -1,2 },{ 1,-2 },{ 1,2 },{ 2,-1 },{ 2,1 } };
bool dfs(int p, int q, int step) {
	pathI[step] = p;
	pathJ[step] = q;
	if (step == col*row) {
		return true;
	}
	for (int i = 0; i < 8; i++) {
		int k = p + dir[i][0];
		int l = q + dir[i][1];
		if ((!visited[k][l]) && k >= 0 && k<row && l >= 0 && l<col) {
			visited[k][l] = 1;
			if (dfs(k, l, step + 1))
				return true;
			visited[k][l] = 0;
		}
	}
	return false;
}
int main() {
	int n;
	cin >> n;
	for (int i = 1; i <= n; i++) {
		cin >> col >> row;
		for (int i = 0; i <= 27; i++)
			for (int j = 0; j <= 27; j++)
				visited[i][j] = 0;
		visited[0][0] = 1;
		cout << "Scenario #" << i << ":" << endl;
		if (dfs(0, 0, 1))
			for (int i = 1; i <= row*col; i++)
				printf("%c%d", pathI[i] + 'A', pathJ[i] + 1);
		else
			cout << "impossible";
		cout << endl;
		if (i != n)
			cout << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值