1056. Mice and Rice (25)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1) where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:

5 5 5 2 5 5 5 3 1 3 5

#include "iostream"
#include "queue"
#include "algorithm"
using namespace std;
int main(){
	queue<int>q;
	int np, ng;
	int w[1002], rank[1002];
	bool flag[1002];
	cin >> np >> ng;
	for (int i = 0; i < np; i++)
		cin >> w[i];
	for (int i = 0; i < np; i++) {
		int m;
		cin >> m;
		q.push(m);
	}
	while(q.size()!=1){
		int nowRank = (q.size() % ng == 0 ? q.size() / ng : q.size() / ng + 1);
		nowRank++;
		queue<int>temp;
		for (int i = 0; i < nowRank-1; i++) {
			int Max = -1;
			int MaxJ = -1;
			for (int j = i*ng; j < i*ng+ng&&q.size()!=0; j++) {
				int index = q.front();
				q.pop();
				if (w[index] > Max) {
					Max = w[index];
					if (MaxJ != -1)
						rank[MaxJ] = nowRank;
					MaxJ = index;
				}
				else {
					rank[index] = nowRank;
				}
			}
			temp.push(MaxJ);
		}
		q = temp;
	}
	rank[q.front()] = 1;
	cout << rank[0];
	for (int i = 1; i < np; i++)
		cout << " " << rank[i];
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值