03-树3 Tree Traversals Again (25分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 3030) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to NN). Then 2N2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

/*
 * 根据push pop操作 可得前中序  从左到右所有的push值即为前序 所有的pop()值即为中序
 * 根据前中序 递归求后序即可。
*/
#include "iostream"
#include "cstring"
#include "string"
#include "stack"
using namespace std;
int n;
int result[62];
int k = 0;
void getPost(int* pre,int* in,int len) { /* 根据前中序得到后序 */
	if (len == 0)
		return;
	int i;
	for (i = 0; in[i] != pre[0]; i++);
	result[k++] = pre[0];
	getPost(pre + i + 1, in + i + 1, len - i - 1);
	getPost(pre+1,in,i);
}
int main() {
	int n;
	char* temp = "Pop";
	char s[62];
	int pre[62];
	int in[62];
	stack<int>sta;
	int cnt = 0;
	int cnt1 = 0;
	cin >> n;
	getchar();
	for (int i = 0; i < n * 2; i++) {
		cin.getline(s, 31);
		int len = strlen(s);
		if (!strcmp(s,temp)) {
			in[cnt++] = sta.top();
			sta.pop();
		}
		else {
			int sum = s[len - 1] - '0';
			if (isdigit(s[len - 2]))
				sum += (s[len - 2] - '0') * 10;
			sta.push(sum);
			pre[cnt1++] = sum;
		}
	}
	getPost(pre,in,cnt);
	k--;
	for (; k >= 0; k--) {
		if (k != 0)
			cout << result[k] << " ";
		else
			cout << result[k];
	}
	cout << endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值