04-树5 Root of AVL Tree (25分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 2020) which is the total number of keys to be inserted. Then NN distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

/*  AVL树。。(各种旋转。。头疼。。。)
 */
#include "iostream"
#include "algorithm"
using namespace std;
typedef struct AVLTreeNode *AVLTree;
typedef int ElementType;
typedef struct AVLTreeNode {
	ElementType val;
	AVLTree left;
	AVLTree right;
	int height;
};
int getHeight(AVLTree t) {
	if (t)
		return max(getHeight(t->left) , getHeight(t->right)) + 1;
	else
		return 0;
}
AVLTree SingleLeftRotation(AVLTree a) { /* 参照陈越版数据结构128页的左单旋的图还是比较好理解的 */
	AVLTree b = a->left;
	a->left = b->right;
	b->right = a;
	a->height = max(getHeight(a->left),getHeight(a->right))+1;
	b->height = max(getHeight(b->left), a->height)+1;
	return b;
}
AVLTree SingleRightRotation(AVLTree t) {
	AVLTree b = t->right;
	t->right = b->left;
	b->left = t;
	t->height = max(getHeight(t->left), getHeight(t->right)) + 1;
	b->height = max(getHeight(b->right),t->height) + 1;
	return b;
}
AVLTree DoubleLeftRightRotation(AVLTree t) {
	t->left = SingleRightRotation(t->left);
	return SingleLeftRotation(t);
}
AVLTree DoubleRightLeftRotation(AVLTree t) {
	t->right = SingleLeftRotation(t->right);
	return SingleRightRotation(t);
}
AVLTree AVL_Insertion(ElementType x,AVLTree t) { 
	/* 插入X到AVL中 并返回调整后的AVL树 */
	if (!t) {
		t = (AVLTree)malloc(sizeof(struct AVLTreeNode));
		t->val = x;
		t->height = 0;
		t->left = t->right = NULL;
	}
	else if (x < t->val) {
		t->left = AVL_Insertion(x, t->left);
		if (getHeight(t->left) - getHeight(t->right) == 2) {
			/*需要左旋*/
			if (x < t->left->val) {
				t = SingleLeftRotation(t);/* 左单旋 */
			}
			else {
				t = DoubleLeftRightRotation(t); /* 左右双旋 */
			}
		}
	}
	else if ( x> t->val) {
		t->right = AVL_Insertion(x, t->right);
		if (getHeight(t->right) - getHeight(t->left) == 2) {
			/*需要左旋*/
			if (x > t->right->val) {
				t = SingleRightRotation(t);/* 左单旋 */
			}
			else {
				t = DoubleRightLeftRotation(t); /* 右左双旋 */
			}
		}
	}
	t->height = max(getHeight(t->left), getHeight(t->right)) + 1;
	return t;
}
void preOrder(AVLTree avl) {
	if (avl) {
		cout << avl->val << " ";
		preOrder(avl->left);
		preOrder(avl->right);
	 }
}
int main()
{
	int n;
	cin >> n;
	AVLTree avl = NULL;
	for (int i = 0; i < n; i++)
	{
		int t;
		cin >> t;
		avl = AVL_Insertion(t, avl);
	}	
	cout << avl->val << endl ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值