03-树3 Tree Traversals Again(25 分)

题目来源:中国大学MOOC-陈越、何钦铭-数据结构-2018春
作者: 陈越
单位: 浙江大学

问题描述:
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
这里写图片描述
Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

解答:压入栈的顺序是前序序列,弹栈的顺序是中序序列,问题转化为,给出前序中序确定一棵树,并后序输出。建树过程主要就是,前序序列的最左边即为根节点,找到中序序列中的根节点,中序根节点以左为左子树,以右为右子树,递归建树即可。

#include <iostream>
#include <stack>
#include <string>
#include <vector>
using namespace std;
const int maxn=30;
int N,inorder[maxn],preorder[maxn];
stack<int> tempStack;
vector<int> postorder;
struct node
{
    int data;
    node* leftChild;
    node* rightChild;
};
node* buildTree(int preL,int preR,int inL,int inR)
{
    node* root=new node();
    if(preL>preR)
        return NULL;
    root->data=inorder[inL];
    //寻找前序中的根节点
    int rootPos,len;
    for(int i=preL;i<=preR;i++)
    {
        if(inorder[inL]==preorder[i])
        {
            rootPos=i;
            break;
        }
    }
    len=rootPos-preL;
    root->leftChild=buildTree(preL,rootPos-1,inL+1,inL+len);
    root->rightChild=buildTree(rootPos+1,preR,inL+len+1,inR);
    return root;
}
void input()
{
    string in;
    int inorderPos=0;
    int preorderPos=0;
    for(int i=0;i<2*N;i++)
    {
        cin>>in;
        if(in[1]=='u')
        {
            int num;
            cin>>num;
            inorder[inorderPos]=num;
            tempStack.push(num);
            inorderPos++;
        }
        else if(in[1]=='o')
        {
            int num=tempStack.top();
            tempStack.pop();
            preorder[preorderPos]=num;
            preorderPos++;
        }
    }
}
void postorderTravel(node* root)
{

    if(root!=NULL)
    {
        postorderTravel(root->leftChild);
        postorderTravel(root->rightChild);
        postorder.push_back(root->data);
    }
}
void output()
{
    for(int i=0;i<postorder.size();i++)
    {
        if(i==0)
            cout<<postorder[i];
        else
            cout<<" "<<postorder[i];
    }
}
int main()
{
    cin>>N;
    input();
    node* tree=buildTree(0,N-1,0,N-1);
    postorderTravel(tree);
    output();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值