06-图2 Saving James Bond - Easy Version(25 分)

题目来源:中国大学MOOC-陈越、何钦铭-数据结构-2018春
作者: 陈越
单位: 浙江大学
问题描述:
This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).
Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.
Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.
Output Specification:
For each test case, print in a line “Yes” if James can escape, or “No” if not.
Sample Input 1:
14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12
Sample Output 1:
Yes
Sample Input 2:
4 13
-12 12
12 12
-12 -12
12 -12
Sample Output 2:
No

解答:一开始没看解析感觉这题好怪,走了些弯路。后来在姥姥的指引下写出来的,感谢。
思维不能僵化,不是必须构造出一个邻接矩阵或者邻接表才能DFS,即使数据结构是数组,也可以根据条件进行DFS,这道题就是这样,把一只只鳄鱼想成点,根据鳄鱼与鳄鱼间的距离作为进行DFS的条件,每次DFS,从未访问的结点中选出距离达标的结点进行访问,判断是否到岸可以想成已鳄鱼为中心的圆是否与岸相切。最后要注意题目中说的diameter是直径,因为这个卡了两个测试点。。
需要注意的就是如何DFS,题目要审清楚,访问过的结点需要标记,回退时要清除标记

#include <iostream>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn=101;
struct Crocodile
{
    int x,y;
};
Crocodile crocodiles[maxn];
int isVisited[maxn];
int N;
float D;
void input()
{
    int x1,y1;
    for(int i=0;i<N;i++)
    {
        cin>>crocodiles[i].x>>crocodiles[i].y;
    }
}
bool isSafe(int x,int y)
{
    //判断能否上岸
    if((50-abs(x)<=D)||(50-abs(y)<=D))
        return true;
    else
        return false;
}
bool DFS(int x,int y,int crocoNum)
{
    bool returnValue=false;
    if(isSafe(x,y))
        return true;
    for(int i=0;i<N;i++)
    {
        float d=(crocodiles[i].x-x)*(crocodiles[i].x-x)+(crocodiles[i].y-y)*(crocodiles[i].y-y);
        if(isVisited[i]==0&&d<=D*D)
        {
            isVisited[i]=1;
            returnValue=DFS(crocodiles[i].x,crocodiles[i].y,i);
            if(returnValue)
                break;
            isVisited[i]=0;
        }
    }
    return returnValue;
}
bool findWay()
{
    fill(isVisited,isVisited+maxn,0);
    bool judge=false;
    if(D>=42.5)
        return true;
    for(int i=0;i<N;i++)
    {
        float d=crocodiles[i].x*crocodiles[i].x+crocodiles[i].y*crocodiles[i].y;
        if(d<=(D+7.5)*(D+7.5)&&isVisited[i]==0)
        {
            isVisited[i]=1;
            judge=DFS(crocodiles[i].x,crocodiles[i].y,i);
        }
        if(judge==true)
            break;
    }
    return judge;
}
int main()
{
    cin>>N>>D;
    input();
    if(findWay())
        cout<<"Yes";
    else
        cout<<"No";
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值