1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

我是用map来解决这道题的,有两个坑,一个是要注意两数(正负)之和为0的情况,还有就是输出格式和精度的问题。AC代码如下:

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <set>
#include <map>
using namespace std;
int main()
{
    int k,i,e,j;
    double c;
    map<int,double>sum_map;
    map<int,double>::iterator iter_map=sum_map.begin();
    cin>>k;
    for(i=0;i<k;++i)
    {
        cin>>e>>c;
        sum_map.insert(pair<int,double>(e,c));
    }
    cin>>k;
    for(i=0;i<k;++i)
    {
        cin>>e>>c;
        if(sum_map.find(e)!=sum_map.end())//exist
        {
            sum_map.find(e)->second+=c;
            if(sum_map.find(e)->second==0)
                j=sum_map.erase(e);
        }
        else//not exist
            sum_map.insert(pair<int,double>(e,c));
    }
    cout<<sum_map.size();
    map<int,double>::reverse_iterator re_iter;
    for(re_iter=sum_map.rbegin();re_iter!=sum_map.rend();++re_iter)
        printf(" %d %.1f",re_iter->first,re_iter->second);

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值