Immediate Decodability

Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:

A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable

HINT

//(如果任意一个串,均不是其它串的前缀则表明,is immediately decodable,否则is not immediately decodable)

#include<stdio.h>
#include<string.h>
int main()
{
	char a[100][100];
	int t=0,i,j,t1,t2,k,s=1;
	while(gets(a[t]))
	{
		t++;
		while(gets(a[t]))
		{
			if(a[t][0]=='9')
				break;
			t++;
		}
		for(i=0;i<t;i++)
		{
			t1=strlen(a[i]);
			for(j=i+1;j<t;j++)
			{
				//t2=strlen(a[j]);
				for(k=0;k<t1;k++)
				{
					if(a[i][k]!=a[j][k])//(is immediately decodable)
						break;
				}
				if(k==t1)//(is not immediately decodable)
					break;
			}
			if(j!=t)//(is not immediately decodable)
				break;
		}
		if(i==t)       
            printf("Set %d is immediately decodable\n",s);
		else
            printf("Set %d is not immediately decodable\n",s);
	
		//for(i=0;i<t;i++)
			//printf("%s\n",a[i]);
	    //printf("\n");	
		t=0;
		s++;
	}
	return 0;
}

 //参考他人代码

单模式匹配算法:给定一个单词和一个字符串,查看字符串中是否存在该单词,通过调用strstr函数进行匹配;

#include<iostream>
#include<string>
#include<stdio.h>
#include<string.h>
 
using namespace std ;
 
int main()  
{
    char word[1000][20] ;
    int t = 1 ;
    while(cin >> word[0])  
	{
        int i = 1 ;
        while(cin >> word[i++])
            if(strcmp(word[i-1],"9")==0)
                break ;
        bool flag = true ;
        i--;
        for(int j = 0 ; j < i ; j++)//每一行均与其它进行比较 
		{
            char *p = NULL ;
            for(int k = 0 ; k < i ; k++)    
			{
                if(j == k)
                    continue ;
                p = strstr(word[j],word[k]) ;//第j行在其它行(k)中遍历,看是否是其前缀。
                 if(p == word[j]) 
	      {
                    flag = false ;
                    break ;
                }
            }
            if(flag == false)
                break ;
        }
        if(flag)
            printf("Set %d is immediately decodable\n",t++) ;
        else
            printf("Set %d is not immediately decodable\n",t++) ;
	}
    return 0 ;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值