Doing Homework again

Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores. 
 

Output

For each test case, you should output the smallest total reduced score, one line per test case. 
 

Sample Input

    
    
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output

    
    
0 3 5
 

//看了一些别人的代码,才开始真的地有了一些想法,,刚开始在排序的过程中打算按时间(从小到大)排序的,若时间相同则按分数从大到小排序,结果发现有点小麻烦,有点写不下去的感觉后来就又换了,,感觉按分数排序(从大到小)较为简单,若分数相同,则按时间从小到大排序
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct zy
{
	int day;
	int score;
};
bool compare(zy x,zy y)
{
	if(x.score==y.score)
		return x.day<y.day;//若分数相同,将时间小的放在前面
	else
		return x.score>y.score;//将分数按从大到小排序
}
int main()
{
	int T;
	cin>>T;
	zy a[2000];
	while(T--)
	{
		int n,i,j;
		cin>>n;
		int flag[2000]={0};//标志无任务
		for(i=0;i<n;i++)
			cin>>a[i].day;
		for(i=0;i<n;i++)
			cin>>a[i].score;
		sort(a,a+n,compare);
		int sum=0;
		for(i=0;i<n;i++)
        {
            for(j=a[i].day;j>=1;j--)
            {
                if(flag[j]==0)
                {
                    flag[j]=1;//代表第j天有已经有任务了	
                    break;
                }
			}
			if(j==0)//代表任务未完成
               sum+=a[i].score;   
		}
		cout<<sum<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值