LightOJ 1245 Harmonic Number (II)

Harmonic Number (II)

Description

I was trying to solve problem '1234 - Harmonic Number', I wrote the following code

long long H( int n ) {
   
 long long res = 0;
   
 for( int i = 1; i <= n; i++ )
        res
 = res + n / i;
   
 return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11

1

2

3

4

5

6

7

8

9

10

2147483647

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5

Case 4: 8

Case 5: 10

Case 6: 14

Case 7: 16

Case 8: 20

Case 9: 23

Case 10: 27

Case 11: 46475828386


解题思路:

(1)直接暴力。

(2)找规律。

1.
n = 10    sqrt(10) = 3     10/sqrt(10) = 3
i        1   2         3   4   5   6   7   8   9   10
n/i    10  5         3   2   2   1   1   1   1    1
 
m =  n/i
sum += m;
m = 1的个数10/1-10/2 = 5;
m = 2的个数10/2-10/3 = 2;
m = 3的个数10/3-10/4 = 1;


 
2.
n = 20     sqrt(20) = 4     20/sqrt(20) = 5
i        1   2   3   4       5   6   7   8   9   10   11   12   13   14   15   16   17   18   19   20
n/i    20  10 6   5       4   3   2   2   2    2     1     1     1     1     1     1     1     1    1    1
 
m =  n/i
sum += m;
m = 1的个数20/1-20/2 = 10;
m = 2的个数20/2-20/3 = 4;
m = 3的个数20/3-20/4 = 1;
m = 4的个数20/4-20/5 = 1;
...
m = i的个数20/i - 20/(i + 1)(1<= i <= sqrt(n))
 
这样我们可以得出:sqrt(n)之前的数我们可以直接用for循环来求
sqrt(n)之后的sum += (n/i - n/(i + 1)) * i;
当sqrt(n) = n / sqrt(n)时(如第一个例子10,sum就多加了一个3),sum多加了一个sqrt(n),减去即可。

AC代码(暴力):

#include <iostream>
#include <cstdio>
using namespace std;

typedef long long ll;

int main(){
    int T,t = 1;
    scanf("%d",&T);
    while(T--){
        ll n;
        scanf("%lld",&n);
        ll ans = 0;
        for(ll i = 1; i <= n;){
            ll tmp = n/i,j = n/tmp;//商为tmp的个数为j
            ans += (ll)tmp*(j-i+1);
            i = j+1;
        }
        printf("Case %d: %lld\n",t++,ans);
    }
    return 0;
}


AC代码(找规律):

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

typedef long long ll;

int main(){
    int T,t = 1;
    scanf("%d",&T);
    while(T--){
        ll n,ans = 0;
        scanf("%lld",&n);
        int m = sqrt(n*1.0);
        for(int i = 1; i <= m; i++)
            ans += n/i;
        for(int i = 1; i <= m; i++)
            ans += (n/i-n/(i+1))*i;
        if(m == n/m)
            ans -= m;
        printf("Case %d: %lld\n",t++,ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值