1038 统计同成绩学生(20)

本题要求读入N名学生的成绩,将获得某一给定分数的学生人数输出。

输入格式:

输入在第1行给出不超过10^5^的正整数N,即学生总人数。随后1行给出N名学生的百分制整数成绩,中间以空格分隔。最后1行给出要查询的分数个数K(不超过N的正整数),随后是K个分数,中间以空格分隔。

输出格式:

在一行中按查询顺序给出得分等于指定分数的学生人数,中间以空格分隔,但行末不得有多余空格。

输入样例:

10
60 75 90 55 75 99 82 90 75 50
3 75 90 88

输出样例:

3 2 0

 分析:这道题还是比较简单的,先上代码:

// B38.cpp : Defines the entry point for the console application.
//

#include <iostream>
using namespace std;

int main()
{
	int n;
	cin >> n;
	int a[100004] = { 0 };
	for (int  i = 0; i < n; i++)
	{
		cin >> a[i];
	}
	int k;
	cin >> k;
	if (k == 0)
	{
		return 0;
	}
	int m;
	int t = 0;
	for (int i = 0; i < k-1; i++)
	{
		cin >> m;
		for (int j = 0; j < n; j++)
		{
			if (m == a[j])
			{
				t++;
			}
		}
		cout << t << " ";
		t = 0;
	}
	cin >> m;
	for (int j = 0; j < n; j++)
	{
		if (m == a[j])
		{
			t++;
		}
	}
	cout << t;
	system("pause");
	return 0;
}

有一个点运行超时,后来从网上查到可以把按下标存储数组。

// B38.cpp : Defines the entry point for the console application.
//


#include <iostream>
using namespace std;

int main()
{
	int n;
	cin >> n;
	int a[101] = { 0 };
	for (int i = 0; i < n; i++)
	{
		int temp;
		cin >> temp;
		a[temp] ++;
	}
	int k;
	cin >> k;
	for (int i = 0; i < k; i++)
	{
		int temp;
		cin >> temp;
		if (i)
		{
			cout << " " << a[temp];
		}
		else
		{
			cout << a[temp];
		}
	}
	
	system("pause");
	return 0;
}

然后,还是运行超时。

我要释放我的终极大杀器了,(嘿嘿,就是把cin/cout改成scanf/printf)

// B38.cpp : Defines the entry point for the console application.
//

#include <iostream>
#include <stdio.h>
using namespace std;

int main()
{
	int n;
	cin >> n;
	int a[101] = { 0 };
	for (int i = 0; i < n; i++)
	{
		int temp;
		//cin >> temp;
		scanf("%d", &temp);
		a[temp] ++;
	}
	int k;
	cin >> k;
	for (int i = 0; i < k; i++)
	{
		int temp;
		cin >> temp;
		if (i)
		{
			//cout << " " << a[temp];
			printf(" ");
			printf("%d", a[temp]);
		}
		else
		{
			//cout << a[temp];
			printf("%d", a[temp]);
		}
	}
	
	system("pause");
	return 0;
}

AC!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值