Checker Challenge(dfs深度搜索 打印八皇后)

Judge Info


  • Memory Limit: 65536KB
  • Case Time Limit: 3000MS
  • Time Limit: 3000MS
  • Judger: Number Only Judger




Description


Examine the 6x6 checkerboard below and note that the six checkers are arranged on the board so that one and only one is placed in each row and each column, and there is never more than one in any diagonal. (Diagonals run from southeast to northwest and southwest to northeast and include all diagonals, not just the major two.)


          Column
    1   2   3   4   5   6
  -------------------------
1 |   | O |   |   |   |   |
  -------------------------
2 |   |   |   | O |   |   |
  -------------------------
3 |   |   |   |   |   | O |
  -------------------------
4 | O |   |   |   |   |   |
  -------------------------
5 |   |   | O |   |   |   |
  -------------------------
6 |   |   |   |   | O |   |
  -------------------------


The solution shown above is described by the sequence 2 4 6 1 3 5, which gives the column positions of the checkers for each row from 1 to 6:


ROW123456
COLUMN246135


This is one solution to the checker challenge. Write a program that finds all unique solution sequences to the Checker Challenge (with ever growing values of N). Print the solutions using the column notation described above. Print the the first three solutions in numerical order, as if the checker positions form the digits of a large number, and then a line with the total number of solutions.


Input


The first number T(1\leq T \leq 10) means how many test cases will followed. For every test case will be a single line that contains a single integer N (6 <= N <= 13) that is the dimension of the N x N checkerboard.


Output


For each test cases, print the follow contains: The first three lines show the first three solutions found, presented as N numbers with a single space between them. The fourth line shows the total number of solutions found.


Sample Input

1
6


Sample Output

2 4 6 1 3 5
3 6 2 5 1 4
4 1 5 2 6 3
4


把八皇后的所有情况打印出来

#include<iostream>
using namespace std;
 
int plc[13];
int plc_p;
int map[13][13];
bool flag[13];
int n;
int ans;
 
void dfs()
{
	if(plc_p==n)
	{
		ans++;
		if(ans<4)
		for(int i=0;i<n;i++)
		{
			if(i!=n-1) cout<<plc[i]+1<<" ";
			else cout<<plc[i]+1<<endl;
		}		
	}
 
	for(int i=0;i<n;i++)
	{
		if((i!=0)&&flag[i-1]==0)
		break;
		if(flag[i]==0)
		{
			flag[i]=1;
			for(int j=0;j<n;j++)
			{
				if(map[i][j]==0)
				{
					for(int k=0;k<n;k++)
					map[k][j]++;
					for(int k=0;k<n;k++)
					map[i][k]++;
					int ii=i,jj=j;
					while(ii>-1&&jj>-1)
					map[ii--][jj--]++;
					ii=i,jj=j;
					while(ii<n&&jj<n)
					map[ii++][jj++]++;
					ii=i,jj=j;
					while(ii>-1&&jj<n)
					map[ii--][jj++]++;
					ii=i,jj=j;
					while(ii<n&&jj>-1)
					map[ii++][jj--]++;
					map[i][j]=1;
					plc[plc_p++]=j;
					dfs();
					plc_p--;
					for(int k=0;k<n;k++)
					map[k][j]--;
					for(int k=0;k<n;k++)
					map[i][k]--;
					ii=i,jj=j;
					while(ii>-1&&jj>-1)
					map[ii--][jj--]--;
					ii=i,jj=j;
					while(ii<n&&jj<n)
					map[ii++][jj++]--;
					ii=i,jj=j;
					while(ii>-1&&jj<n)
					map[ii--][jj++]--;
					ii=i,jj=j;
					while(ii<n&&jj>-1)
					map[ii++][jj--]--;
					map[i][j]=0;
				}
			}
			flag[i]=0;
		}
	}
}
 
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		cin>>n;
		for(int i=0;i<n;i++)
		int plc_p=0;
		for(int i=0;i<n;i++)
		for(int j=0;j<n;j++)
		map[i][j]=0;
		for(int i=0;i<n;i++)
		flag[i]=0;
		ans=0;
		dfs();
		cout<<ans<<endl;
	}
	return 0;
}


dfs的基本过程:

dfs()

判明终止条件

for全部物件

标记

dfs()

恢复




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值