hdu 1018

Big Number

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
 
 
21020
 
Sample Output
 
 
719
 
/*
做法:求n的阶乘的位数(1<=n<10000000)
      当n=10000000时,n的阶乘将是一个超级无敌大的数,无法想象。 
      然后看了一些大神们独辟蹊径的想法,不看我绝对想不出来,涨姿势了 
      任意一个正整数a的位数等于 (int)log10(a) + 1;
      现在来求n的阶乘的位数:n!=1*2*3*......*n
	  那么我们要求的就是(int)log10(n!)+1
	   log10(n!)=log10(1*2*3*......n)
      =log10(1)+log10(2)+log10(3)+......+log10(n)
      所以n的阶乘的位数等于
	  (int)(log10(1)+log10(2)+log10(3)+......+log10(n)) + 1
*/
#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstdlib>
using namespace std;
int main()
{
	int T;
	int n;
	scanf("%d",&T);
	while(T--)
	{
		double ans=0;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			ans+=(log10(i));
		}
		printf("%d\n",(int)ans+1);
	}
	return 1;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值