思维 POJ-1323

Game Prediction
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 10745
Accepted: 5189

Description

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game.

Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.

Input

The input consists of several test cases. The first line of each case contains two integers m (2?20) and n (1?50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases.

The input is terminated by a line with two zeros.

Output

For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.

Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0

Sample Output

Case 1: 2
Case 2: 4


题意:m个人玩游戏,每个人n张卡,最大点数为n*m,没有相同点数的卡牌,每轮出一张卡,问你至少能赢的最大回合数。

将自己的卡牌按点数排序,当前自己最大则出,否则丢掉最小的一张,其他玩家也是如此做。那么从n*m开始往下遍历,如果没有当前点数,那么别人多了一张比我大的牌,但他会比我最大的牌大的他自己的最小点数。一旦别人没有比我大的牌,就可以出。


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
int num[1050];

int main()
{
    int m, n, cas = 1, t;
    while(~scanf("%d%d", &m, &n) && n && m) {
        memset(num, 0, sizeof(num));
        for(int i = 0; i < n; i++) {
            scanf("%d", &t);
            num[t] = 1;
        }
        int ans = 0, big = 0; // big表示比我最大的那张还大的次数
        for(int i = n * m; i >= 0; i--) {
            if(num[i]) {
                if(!big) ans++; // 没有比我大的牌,胜利+1
                else --big; // 否则,丢掉一张我的最小的牌
            }
            else
                ++big; // 别人有比我大的牌+1
        }
        printf("Case %d: %d\n", cas++, ans);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值