贪心算法I题

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game.
Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.

Input
The input consists of several test cases. The first line of each case contains two integers m (2 <= m <= 20) and n (1 <= n <= 50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases.
The input is terminated by a line with two zeros.

Output
For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.

Sample Input
2 5
1 7 2 10 9
6 11
62 63 54 66 65 61 57 56 50 53 48
0 0
Sample Output
Case 1: 2
Case 2: 4

题意

m个玩游戏,包括你在内,每人摸n张牌,最大的牌面是n*m,任何两张牌都不相同,你可以选择一个人作为对手,或者不选择对手。你出一张,对手出一张,谁牌大谁就赢,打过的牌不能重复使用。求你至少赢几次?

思路

田忌赛马思想

至少赢几次,就是你和一个最强的对手打,以你的牌为参考,从i=n*m开始,如果你有i号牌,那么i–;如果你没有i号牌,那么就把它给假定的最强对手。当你们两人牌数相同时,开始对决。

如果你的最大的牌如果比他最大的牌大,那就你赢一局,但是是至少赢几局,所以默认是对手拿最小的牌代替他的当前的最大的牌来和你比较,然后他丢弃最小的牌,最大的牌还留着下一轮和你比较;

如果你的最大的牌小于他当前最大的牌,那你就必输,你们双方的最大牌都要丢弃。

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int my[55],ot[55];
bool pd[1005];
int main(){
    int n,m,t=0;
    while(cin>>m>>n&&n&&m){
        for(int i=0;i<n;i++){
            cin>>my[i];
            pd[my[i]]=true;
        }
        sort(my,my+n);
        int ct=0;
        //给对手分尽可能大的牌
        for(int i=n*m;ct<n;i--){
            if(!pd[i])ot[ct++]=i;
        }
        int sum=0;
        //你的牌打完就等同于他的牌也打完
        for(int i=n-1,k=0;i>=0;i--){
            if(my[i]>=ot[k])sum++;//赢,但是对方丢弃最小的牌,保留最大的牌,而你要换牌
            else k++;//双方换牌
        }
        cout<<"Case "<<++t<<": "<<sum<<endl;
        memset(pd,false,sizeof(pd));
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
当涉及到背包问时,贪心算法是一种常用的解决方法。在C语言中,可以使用贪心算法来解决背包问。下面是一个简单的C语言贪心算法背包问的代码示例: ```c #include <stdio.h> // 定义物品结构体 typedef struct { int weight; // 物品重量 int value; // 物品价值 } Item; // 贪心算法背包问函数 void knapsack(Item items[], int n, int capacity) { // 计算物品的性价比(价值除以重量) float ratios[n]; for (int i = 0; i < n; i++) { ratios[i] = (float) items[i].value / items[i].weight; } // 按照性价比排序物品 for (int i = 0; i < n - 1; i++) { for (int j = 0; j < n - i - 1; j++) { if (ratios[j] < ratios[j + 1]) { // 交换物品的位置 float tempRatio = ratios[j]; ratios[j] = ratios[j + 1]; ratios[j + 1] = tempRatio; Item tempItem = items[j]; items[j] = items[j + 1]; items[j + 1] = tempItem; } } } // 装入背包 int currentWeight = 0; float totalValue = 0; for (int i = 0; i < n; i++) { if (currentWeight + items[i].weight <= capacity) { // 将物品放入背包 currentWeight += items[i].weight; totalValue += items[i].value; } else { // 物品只能部分放入背包 int remainingWeight = capacity - currentWeight; totalValue += ratios[i] * remainingWeight; break; } } // 输出结果 printf("背包中物品的总价值为: %.2f\n", totalValue); } int main() { // 创建物品数组 Item items[] = { {10, 60}, {20, 100}, {30, 120} }; int n = sizeof(items) / sizeof(items[0]); // 物品数量 int capacity = 50; // 背包容量 // 调用贪心算法背包问函数 knapsack(items, n, capacity); return ; } ``` 这段代码实现了一个简单的贪算法背包问。它首先计算每个物品性价比,然后按照性价比对物品进行排序。接下来,它从性价比最高的物品开始,依次将物品放入背包,直到背包装满或者所有物品都放入背包。最后,输出背包中物品的总价值。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值