Minimum’s Revenge

                                             Minimum’s Revenge

                                                                      Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
                                                                      Total Submission(s): 1020    Accepted Submission(s): 544


Problem Description
There is a graph of n vertices which are indexed from 1 to n. For any pair of different vertices, the weight of the edge between them is the least common multiple of their indexes.

Mr. Frog is wondering about the total weight of the minimum spanning tree. Can you help him?
 

Input
The first line contains only one integer T ( T100 ), which indicates the number of test cases.

For each test case, the first line contains only one integer n ( 2n109 ), indicating the number of vertices.
 

Output
For each test case, output one line "Case #x:y",where x is the case number (starting from 1) and y is the total weight of the minimum spanning tree.
 

Sample Input
  
  
2 2 3
 

Sample Output
  
  
Case #1: 2 Case #2: 5
Hint
In the second sample, the graph contains 3 edges which are (1, 2, 2), (1, 3, 3) and (2, 3, 6). Thus the answer is 5.
 简要分析:
有n个节点的图,顶点编号1-n,任意连接两个不同的顶点的边的权值为这两个顶点编号的最小公倍数,求该图最小生成树的权值和。
注意到任何顶点与1号顶点相连的边的权值为最小,那么该题就转化为2+3+4+...+n求和。
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <queue>
#include <string.h>
#include <stack>
#include <vector>
#define LL long long

int main()
{

    int mycase=1;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        LL n;
        scanf("%d",&n);
        LL ans=(2+n)*(n-1)/2;  //数据规模过大,用long long型
        printf("Case #%d: %lld\n",mycase,ans);
        mycase++;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值