poj3624 Charm Bracelet

Charm Bracelet

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44500 Accepted: 19078
Description

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7
Sample Output

23

题目解析:

这个题目是一个很简单的dp问题,也是dp中最常见的01背包模板题目,首先灌输一下什么是01背包问题,01背包问题就是说有n个物品,每个物品数量是有限制的,每个物品有一个价值,给你一个容量为W的背包,问可以装物品的最大价值是多少,对于这个题目也是一样,首先我们可以设dp[i]表示容量为i的背包最多可以装物品的价值,所以很容易得到动态转移方程,dp[i] = max(dp[i],dp[i-w[j]]);
有什么不懂得可以直接评论或者私聊我。
下面将会给出c++和java两种代码,菜鸟代码,大佬勿喷,有错误请指出,谢谢合作

c++代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 200000;
int w[maxn],v[maxn],dp[maxn];
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        for(int i=0; i<n; i++)
            cin>>w[i]>>v[i];
        int ans = 0;
        for(int i=0; i<n; i++)
            for(int j=m; j>=w[i]; j--)
            {
                dp[j] = max(dp[j],v[i]+dp[j-w[i]]);
                ans = max(ans,dp[j]);
            }
        cout<<ans<<endl;
    }
    return 0;
}

java代码

import java.util.Scanner;

public class Main {
    public static void main(String args[]){
        int n = 0,W = 0,ans = 0;
        Scanner cin = new Scanner(System.in);
        int []v = new int[200000];
        int []w = new int[200000];
        int []dp = new int[200000];
        n = cin.nextInt();
        W = cin.nextInt();
        for(int i=0;i<n;i++){
                w[i] = cin.nextInt();
                v[i] = cin.nextInt();
        }
        for(int i=0;i<n;i++)
            for(int j=W;j>=w[i];j--){
                dp[j] = Math.max(dp[j],dp[j-w[i]]+v[i]);
                ans = Math.max(ans,dp[j]);
            }
        System.out.println(ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值