山东省第八届acm省赛C题 fireworks

题目来戳呀

Problem Description

Hmz likes to play fireworks, especially when they are put regularly.
Now he puts some fireworks in a line. This time he put a trigger on each firework. With that trigger, each firework will explode and split into two parts per second, which means if a firework is currently in position x, then in next second one part will be in position x−1 and one in x+1. They can continue spliting without limits, as Hmz likes.
Now there are n fireworks on the number axis. Hmz wants to know after T seconds, how many fireworks are there in position w?
这里写图片描述

Input

Input contains multiple test cases.
For each test case:
The first line contains 3 integers n,T,w(n,T,|w|≤10^5)
In next n lines, each line contains two integers xi and ci, indicating there are ci fireworks in position xi at the beginning(ci,|xi|≤10^5).

Output

For each test case, you should output the answer MOD 1000000007.

Example Input

1 2 0
2 2
2 2 2
0 3
1 2

Example Output

2
3

题意:
放烟花,在xi位置上有ci个烟花,1秒钟一个分成两个,前一个后一个,此位置上的就没了。
一共有n个位置,问t秒后,在w位置上有多少个烟花。

想法:
写几组数据,用图的形式展开来(不要紧巴巴的真的就在数轴写啊+_+鬼能看出来啊)
某个位置上的图写出来发现类似杨辉三角,但是中间是加了0的
0 0 0 0 0 1 0 0 0 0 0
0 0 0 0 1 0 1 0 0 0 0
0 0 0 1 0 2 0 1 0 0 0
0 0 1 0 3 0 3 0 1 0 0
0 1 0 4 0 6 0 4 0 1 0
当所在的位置的奇偶性和时间的奇偶性相同时,发现符合杨辉三角。
符合杨辉三角的部分,即求组合数,C(n,m)=n!/m!(n-m)!,再对1e9+7取模;
因为取模之前的结果太大了,所以我们通过乘法逆元的方法来求,即除以一个数等于乘以这个数的逆元再取模,这位的逆元写的贼好
乘法逆元这里选择用快速幂的方法来求。
不符合杨辉三角的就是0。


#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
typedef long long ll;
const int mod=1e9+7;
ll arr[100010];
void init()//求阶乘
{
    arr[0]=arr[1]=1;
    for(int i=2;i<=1e5;++i)
        arr[i]=(arr[i-1]*i)%mod;
}
ll PowerMod(ll a, ll b)//快速幂
{
    ll ans=1;
    a=a%mod;
    while(b>0)
    {
        if(b&1)
            ans=(ans*a)%mod;
        b>>=1;
        a=(a*a)%mod;
    }
    return ans;
}
ll cn(ll n,ll m)
{
    return ((arr[n]*PowerMod(arr[n-m],mod-2))%mod*PowerMod(arr[m],mod-2))%mod;
}
int main()
{
    init();
    int n,t,w;
    while(cin>>n>>t>>w)
    {
        ll ans=0;
        while(n--)
        {
            ll ci,xi;
            cin>>xi>>ci;
            ll k=abs(w-xi);//求绝对值
            if((k&1)==(t&1)&&k<=t)//奇偶性相同就符合杨辉三角并且在时间范围内
                ans=(ans+(ci*cn(t,(k+t)/2))%mod)%mod;
        }
         cout<<ans<<endl;
    }
    return 0;
}

ps: 哇卡哇卡不出来了QAQ

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值